• Special Characters & symbols active when typing on new install.


    I installed Antergos this morning and since installation I am experiencing issues with special characters or symbols appearing as I am attempting to execute code in the terminal or type in applications. Such symbols include é when typing / from the main keyboard layout, # for tilda, and a host of other symbols. These seem to persist after multiple reboots.

    Where can I look to rectify this issue?

    UPDATE
    The issue was fixed by:

    localectl set-x11-keymap us
    
  • Desktop = ? Gnome Kde e.t.c.

  • @joekamprad Oh, sorry, I am using i3. This issue happens in tty as well.

  • cat /etc/locale.conf
    
    cat /etc/vconsole.conf
    

    will give you what is setup for systemwide

    and:
    to change settings inside locale.conf

    #sudo nano /etc/locale.gen
    #sudo locale-gen
    
  • @joekamprad Keymap is US but

    LC_COLLATE=en_CA.UTF-8
    

    even after reboot.

    Update

    en_US.UTF-8 UTF-8
    

    in /etc/locale.gen

  • Give me the output of this two commands plz.:

    cat /etc/locale.conf
    cat /etc/vconsole.conf
    
  • @joekamprad said in Special Characters & symbols active when typing on new install.:

    Give me the output of this two commands plz.:

    cat /etc/locale.conf
    cat /etc/vconsole.conf
    
    LANG=en_US.UTF-8
    
    KEYMAP=us
    

    I ran localectl set-x11-keymap us-utf-8 but this may be the wrong input IMO.

    localectl status

    System Locale: LANG=en_US.UTF-8
    VC Keymap: n/a
    X11 Layout: us-utf-8
    

    UPDATE
    The issue was fixed by:

    localectl set-x11-keymap us
    
  • now i learn something ;)
    I forget about localectl

  • @joekamprad 👍
    How do I mark solved?

  • theme tools > mark as solved

terminal42 font30 fontrendering5 fontcharacter2 Posts 10Views 1369
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.