• Can't lock user/screen or sign out


    I recently installed ZSH on my Antergos laptop (which replaced my user’s bash with zsh).
    I then uninstalled it, incorrectly, and when I rebooted my computer I couldn’t log in as my user.
    I signed in as root and then, following a tutorial on google, uninstalled LightDM and installed gdm so that I could use a GUI rather than being forced to use TTY.
    When I figured out that the issue was ZSH being uninstalled incorrectly, I reinstalled it, rebooted, and I could sign into my account again, but now I can’t lock my laptop or sign out of my account. I uninstalled gdm and reinstalled LightDM and also re-enabled it with sudo systemctl enable -f lightdm.

    How do I fix the LightDM setup so that I can lock my computer again?

  • you need light-locker to reinstall also then… and light-locker-settings…

    sudo pacman -S light-locker  light-locker-settings
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad Thank you for the response

    Lightdm-locker is installed (light-locker), as is light-locker-settings.
    How do I activate it? Do I need to reboot for it to take effect?

  • saettings are useless on Gnome DE but if it works before on your system you need to reboot to make shure, but may logout and in will do the job too…
    You can run light-locker-settings it is the settings GUI, to setup as you want.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I’ll reboot as soon as I am able and will let you know on the progress.

  • @joekamprad I rebooted my laptop, signed in, waited a moment, and then pressed SUPER + L to lock my laptop and nothing happened.

    Edit: There is no log out or lock buttons in the top-bar drop down status menu. There is only Settings and Power now. There used to be Lock and Log Out buttons.

  • looks like a Gnome desktop?
    you need to enable extensions with the main locker (top right) inside gnome-tweak-tool:
    Bild Text

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad Yeah, it is a Gnome Desktop.
    Extensions are already enabled.

    0_1493221347751_upload-e0a148b4-5b3a-4979-ab33-60a64c5c0b8f

  • And before your misstake it works?
    Because i try alot of times to get this worked out with lightdm and light-locker and never solved to get it running with Gnome.

    there is this extension:
    gnome-shell-extension-status-menu-buttons

    Should bring you the buttons back.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Before my mistake in uninstalling Lightdm, yes, it worked perfectly with a Gnome setup.
    I installed the extension and the buttons are back, but they don’t do anything.

  • I have no clue then…
    try to open a terminal with this command:

    journalctl -f
    

    and look if something is pasted inside while pressing the buttons

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    I ran journalctl -f and pressed the buttons but nothing happened.
    I test pressing SUPER+L while journalctl -f was running and it printed this line:

    Apr 26 20:17:11 apocalypse gsd-media-keys[1129]: Couldn't lock screen: \
    Cannot invoke method; proxy is for a well-known name without an owner \
    and proxy was constructed with the G_DBUS_PROXY_FLAGS_DO_NOT_AUTO_START flag
    
  • *Couldn’t lock screen: * yes a very detailed information, we do not see this before ;)
    As i do not use lightdm anymore and lightlocker-settings does not save the settings i have no more idea.
    Sorry!

    With GDM everything works as it has to lock the session power off monitor e.t.c. without any special investigation…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    I noted there’s a Xsession file in /etc/lightdm/.
    I tested running it and this was the output:

    Running X session wrapper
    Loading profile from /etc/profile
    Loading xinit script /etc/X11/xinit/xinitrc.d/40-libcanberra-gtk-module.sh
    Loading xinit script /etc/X11/xinit/xinitrc.d/50-systemd-user.sh
    Failed to connect to bus: No such file or directory
    dbus-update-activation-environment: error: unable to connect to D-Bus: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead
    X session wrapper complete, running session
    

    Any idea what that could mean?

    Edit: it’s because I was running it as root.

  • can you post:

    pacman -Qs lightdm
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • and do you try setting it up with light-locker-settings?
    If you want to use lightdm-gtk-greeter you need to change the greeter session option inside

    sudo nano /etc/lightdm/lightdm.conf
    

    greeter-session=lightdm-gtk-greeter

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    I’m using the webkit2 greeter. Do I need to use the gtk greeter?

    My /etc/lightdm/lightdm.conf:greeter-session=lightdm-gtk-greeter: is set to greeter-session=lightdm-webkit2-greeter

    0_1493276443895_upload-e6d4350c-b5a9-41f7-bc99-fad0d5552cc4

  • @thepie no no need for lightdm-gtk-greeter same same as webkit greeter… i say this only because you have it installed…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad

    Thank you for the help, apologies for the delayed response.
    I’m using a workaround by binding SUPER+L to execute the command dm-tool lock.
    I’ll mark the topic as solved. Thank you.

sign out1 lock user2 lightdm93 gdm33 Posts 20Views 748
Log in to reply