• openssl-1.0: /usr/lib/libcrypto.so.1.0.0 exists in filesystem


    Today my system update failed. I ran

    sudo pacman -Syu
    

    as I always do, but in the end I got this message:

    error: failed to commit transaction (conflicting files)
    openssl-1.0: /usr/lib/libcrypto.so.1.0.0 exists in filesystem
    openssl-1.0: /usr/lib/libssl.so.1.0.0 exists in filesystem
    

    Any clue what to do? Thanks in advance.

  • Are you using AUR Builds too?
    then you need to update them too… [yaourt -Syua would do all together]

    For what do you need the older openssl-1.0 is the question?

    May you are using spotify?

    install pkgtools {good to have them installed anyways}

    yaourt -S pkgtools
    
    whoneeds openssl-1.0
    

    Short?
    uninstall spotify:

    pacman -Rsn spotify
    

    upgrade the system

    yaourt -Syua
    

    reinstall spotify:

    yaourt -S spotify
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Yes, Spotify, QMapShack, QLandkarteQT. And a couple of others :-)

    [[email protected]]$ whoneeds openssl-1.0
    Packages that depend on [openssl-1.0]
      akonadi-calendar-tools
      akonadiconsole
      akonadi-import-wizard
      akregator
      ark
      blogilo
      bluedevil
      breeze
      breeze-gtk
      calibre
      digikam
      discover
      dolphin
      dolphin-plugins
      drkonqi
      filelight
      gebabbel
      gpsbabel
      grantlee-editor
      gwenview
      kactivitymanagerd
      kaddressbook
      kalarm
      kamera
      kate
      kcalc
      kcolorchooser
      kdebugsettings
      kde-cli-tools
      kdeconnect
      kdecoration
      kdegraphics-mobipocket
      kde-gtk-config
      kdenetwork-filesharing
      kdepim-addons
      kdeplasma-addons
      kdeutils-kremotecontrol
      kdeutils-sweeper
      kdf
      kfloppy
      kgamma5
      kgpg
      khotkeys
      kcharselect
      kinfocenter
      kipi-plugins
      kleopatra
      kmail
      kmail-account-wizard
      kmenuedit
      knetattach
      knotes
      konsole
      kontact
      korganizer
      kscreen
      kscreenlocker
      ksshaskpass
      ksysguard
      kteatime
      ktimer
      kuiserver
      kwalletmanager
      kwayland-integration
      kwin
      kwrited
      libkscreen
      libksysguard
      mbox-importer
      milou
      okular
      oxygen
      pim-data-exporter
      pim-sieve-editor
      pim-storage-service-manager
      plasma-desktop
      plasma-integration
      plasma-nm
      plasma-pa
      plasma-sdk
      plasma-workspace
      plasma5-applets-redshift-control
      polkit-kde-agent
      powerdevil
      print-manager
      pulseaudio-equalizer
      pytrainer
      qlandkartegt
      qt5-styleplugins
      quazip
      sddm-kcm
      shashlik-bin
      spectacle
      systemsettings
      user-manager
      virtualbox
      yakuake
    

    I have already tried tu remove Spotify, update, reinstall, just the way you suggest. All I get is

    error: failed to commit transaction (conflicting files)
    openssl: /usr/lib/libcrypto.so.1.1 exists in filesystem
    Errors occurred, no packages were upgraded.
    error: file owned by 'openssl' and 'openssl-1.0': 'usr/lib/libcrypto.so.1.0.0'
    error: file owned by 'openssl' and 'openssl-1.0': 'usr/lib/libssl.so.1.0.0'
    
  • as i say reason is the openssl update… and the new package what is a “placeholder” for apps needs the older openssl libs…

    can you try to uninstall openssl-1.0 :

    pacman -Rsn openssl-1.0
    

    This may calls several packages to uninstall can you give the output before doing transaction?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

filesystem3 openssl-1.02 exists2 Posts 4Views 2243
Log in to reply