• Nvidia antergos iso borked, official ISO no go, blacklisting nouveau

    So I’m trying to get Antergos installed and I’ve read this wiki about installing with a newer GPU

    nstalling-antergos-with-a-newer-nvidia-gpu – won’t let me post the link as it thinks it’s spam…

    Downloaded the nvidia iso that the user made in that wiki page. Booted it and got inside the live environment. Cnchi goes through the installer and errors out and never actually installs. Gave me an error: 567XXX or something.

    Thought it was a bad USB I made, so I remade it and this time using the same ISO cnchi won’t even get past the “Choose your language” screen.

    So I download the official ISO (the minimal one) and at the boot screen (black screen with options)

    Selected the "Antergox x86_64 option (first one) and hit “E”. Typed nomodeset at the end of the line, nothing. Still get the EE errors.

    Nothing I try is able to get me anywhere close to installing it. The only thing that got me close was the nvidia iso, but it’s causing the installer to freeze and just stop working, etc.

    Anyone care to help me out with this please. Have been trying to get this installed for 4 hours now -_-.

  • Hi,

    Nouveau driver (the open one) does not work with the newest nvidia cards.

    As you have guessed, you can use that non oficial iso to install your system (it’s like the original iso but with the nvidia driver instead of nouveau).

    You should also add nomodeset with that iso (like you did with the official one).

    If Cnchi still fails, check /tmp/cnchi.log file. There you will find more info about the error.


  • Second way is (if you have a PC with internal graphiccard) to remove Nvidia-Card and use the internal one.
    Some Systems allow to disable also in Bios. Plug in your Display to internal card and install with official Iso.
    Reboot, install nvidia installer:

    sudo pacman -S nvidia-installer
    sudo nvidia-installer -t

    if no error is shown:

    sudo nvidia-installer

    power off system, plug monitor to nvidia card power on…done

  • I should of thought to check /tmp/cnchi.log for errors. Maybe I should of just went to sleep rather than trying to fix it at 3am -_-.

    Trying again and will check there if any errors happen or it just freezes.

  • Ok, I get back into the cnchi installer, this time however, it keeps giving me a cannot download metadata package list error (577339).

    Happens with any options I select on the package selection list. Weird as it never gave this to me last time I installed Antergos about a 6 months ago with the same nvidia ISO.

    EDIT: Ok, this time I deselected everything except AUR and extra fonts and get the same error but with code 577346.

  • I didn’t see anything wrong in the logs from Googling so I just updated cnchi via pacman and it seems to be working now.

  • @karasu What do you think about adding some of the most common boot options in the installer options, i mean:

    • Boot HD
    • Start livecd
    • Advanced
      - Nomodeset (and can add some comments, like, if you get black screen with the “start livecd” option)
      - Bablabla (if you use X graphical card)

    Just wanted to say that, sorry for going offtopic.

  • It’s already done: https://github.com/antergos/antergos-iso/tree/testing

    But we need to merge it with master and test it.

nvidia165 iso83 official8 borked1 Posts 8Views 1536
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.