• error: failed to prepare transaction (could not satisfy dependencies)


    Today I wan’t to do full system update. But this happened.

    pacman -Syu
    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date                 0.0   B  0.00B/s 00:00 [-----------------------------------]   0%
     multilib is up to date
     blackarch is up to date
     pantheon is up to date
     liri-unstable is up to date
    :: Starting full system upgrade...
    warning: handbrake: ignoring package upgrade (1.0.2-1 => 1.0.7-2)
    warning: ppsspp-qt: ignoring package upgrade (1.1.1-2 => 1.4-2)
    warning: vlc: ignoring package upgrade (2.0.8.a-1 => 2.2.4-8)
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: gstreamer0.10-good-plugins: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'
    

    That message above is after I remove gnome-shell-frippery. Before that, It said gnome-shell-frippery breaks gnome-shell, and gnome shell breaks ‘i forgot what’.

    What should I do? Should I remove libsoup? Is it safe? That gstreamer and libsoup sounds important.
    Thank you :)

  • Hi, that particular gstreamer package was moved from the official repos to the AUR a few months ago. Its safe to remove it and that is what I recommend you do to resolve the conflict

    Cheers! :smiley:

  • Thank you

  • pacman -Qs gstreamer0.10
    if it finds packages remove them too they are old and useless…
    new ones called:
    pacman -Ss gst-plugins

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

syu3 pacman68 Posts 4Views 294
Log in to reply