• Openssl 1.1.0e update breaks Spotify compatibility

    I applied the Openssl 1.1.0e, while the previous one was 1.0.2k.

    Now I can’t start Spotify anymore. I get this message:

    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)

    I tried pacman -U to downgrade to the previous version but it fails, printing this error:

    fout:fout bij het uitvoeren van de transactie (conflicterende bestanden)
    openssl: /usr/lib/libcrypto.so.1.0.0 bestaat in bestandssysteem
    openssl: /usr/lib/libssl.so.1.0.0 bestaat in bestandssysteem

    It says that these files already exist in the filesystem.

    Anyone have any idea on how to fix this?

    Edit: I just noticed that there’s an update for Spotify too, but this one fails with the error that the GPG signature could not be verified.

  • @EarthMind Insteresting, i was playing around with Pacbang here and faced the same problem.
    Although your error is in German i guess it’s the same, i downloaded the version openssl-1.0-1.0.2.k-3-x86_64.pkg.tar.xz from http://ala.seblu.net/packages/o/openssl-1.0/ extracted the files and them manually placed the 2 missing libs in /usr/lib.

    Portergos site

    Still in love with Antergos (default OS)

    Linux newbie since 06/2016

  • Try and reinstall spotify again. Maintainer fixed the issue.

  • Still the same issue with the PGP key verification I’m afraid.

    I’m currently trying the solution from the comments: https://aur.archlinux.org/packages/spotify/

  • $ gpg --recv-key 5CC908FDB71E12C2
    $ gpg --recv-key D9C4D26D0E604491
    $ yaourt -S spotify


  • Yep that solves it. I just hope that Openssl on my system didn’t get messed up and cause other software not to function…

  • Spoyify uses libopenssl-1.0-compat and libcurl-openssl-1.0 from aur (at least for now), they are completely separate from openssl package. That’s why you need those keys. So no need to worry about your system.

  • @psscnp142 said in Openssl 1.1.0e update breaks Spotify compatibility:

    $ gpg --recv-key 5CC908FDB71E12C2
    $ gpg --recv-key D9C4D26D0E604491
    $ yaourt -S spotify


    That Keys doesnt work for me…

    ==> Verificando las firmas de las fuentes con gpg…
        curl-7.54.0.tar.gz ... HA FALLADO
    ==> ERROR: ¡Una o más firmas PGP no pudieron ser verificadas!
    ==> ERROR: Makepkg no ha podido compilar libcurl-openssl-1.0.
    ==> ¿Reiniciar la compilación de libcurl-openssl-1.0? [s/N]

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • This post is deleted!
breaks20 spotify9 openssl3 1.1.0e1 Posts 9Views 1941
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.