• Lib version not found (required by)


    I deleted and then installed gnome. Now i get it:

    [[email protected] ~]$ spotify
    /usr/share/spotify/spotify: /usr/lib/libssl.so.1.0.0: version "OPENSSL_1.0.0" not found (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto.so.1.0.0: version "OPENSSL_1.0.0" not found (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl.so.3: no version information available (required by /usr/share/spotify/spotify)
    [[email protected] ~]$ ls /usr/lib/libssl*
    /usr/lib/libssl.so  /usr/lib/libssl.so.1.0.0  /usr/lib/libssl.so.1.1
    [[email protected] ~]$ ls /usr/lib/libcurl*
    /usr/lib/libcurl-compat.so.4.4.0  /usr/lib/libcurl.so
    /usr/lib/libcurl-gnutls.so.3      /usr/lib/libcurl.so.3
    /usr/lib/libcurl-gnutls.so.4      /usr/lib/libcurl.so.4
    /usr/lib/libcurl-gnutls.so.4.0.0  /usr/lib/libcurl.so.4.0.0
    /usr/lib/libcurl-gnutls.so.4.1.0  /usr/lib/libcurl.so.4.1.0
    /usr/lib/libcurl-gnutls.so.4.2.0  /usr/lib/libcurl.so.4.2.0
    /usr/lib/libcurl-gnutls.so.4.3.0  /usr/lib/libcurl.so.4.3.0
    /usr/lib/libcurl-gnutls.so.4.4.0  /usr/lib/libcurl.so.4.4.0
    [[email protected] ~]$ ls /usr/lib/libcrypto*
    /usr/lib/libcrypto.so  /usr/lib/libcrypto.so.1.0.0  /usr/lib/libcrypto.so.1.1
    [[email protected] ~]$
    

    I tried reinstall openssl, curl. It did not help((

  • Thats funny ūüėČ we have the opposite before it was linked to the newer /usr/lib/libssl.so.XXX and now openssl is updated and spotify links to the older one‚Ķ
    https://aur.archlinux.org/packages/spotify/ >>Last Updated: 2017-04-25 07:13

    You may need to rebuild spotify

    yaourt -Syy spotify
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • pacman-key --refresh-keys
    

    Shows

    Gpg: [dont know]: invalid packet (ctb = 02)
    Gpg: keyring_get_keyblock: read error: Invalid package
    Gpg: keyring_get_keyblock failed: Wrong key table
    Gpg: key table rebuilding failed: Wrong key table
    Gpg: marginals needed: 3 completes needed: 1 trust model: pgp
    Gpg: [do not know]: invalid packet (ctb = 1b)
    Gpg: keyring_get_keyblock: read error: Invalid package
    Gpg: keydb_get_keyblock failed: Wrong key table
    Gpg: validate_key_list failed
    ==> ERROR: Failed to update the specified local key from the key server.
    

    And when i trying install spotify update

    ==> Checking the signatures of the source files with 'gpg' ...
         Openssl-1.0.2k.tar.gz ... FAILURE (unknown public key D9C4D26D0E604491)
    ==> ERROR: One or more PGP signatures can not be verified!
    
    

    I tried

    SigLevel    = Never
    

    But it did not help

  • Solved

    gpg --recv-keys --keyserver hkp://pgp.mit.edu D9C4D26D0E604491
    gpg --recv-keys --keyserver hkp://pgp.mit.edu 5CC908FDB71E12C2
    
    yaourt -S libopenssl-1.0-compat libcurl-openssl-1.0 spotify
    

    Spotify works but i get warns.

    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /proc/self/exe: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /proc/self/exe: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    
  • @woan said in Lib version not found (required by):

    Solved

    gpg --recv-keys --keyserver hkp://pgp.mit.edu D9C4D26D0E604491
    gpg --recv-keys --keyserver hkp://pgp.mit.edu 5CC908FDB71E12C2
    
    yaourt -S libopenssl-1.0-compat libcurl-openssl-1.0 spotify
    

    but i get warns. Spotify works

    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/share/spotify/spotify)
    /usr/share/spotify/spotify: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /usr/share/spotify/spotify: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /proc/self/exe: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /proc/self/exe)
    /proc/self/exe: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    /proc/self/exe: /usr/lib/libcrypto-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)
    

    Using the gpg commands and then performing yaourt -S spotify solved the issue for me. Thanks very much for posting this here!!!

  • This keep me sending the same error:

    Validando los archivos source con sha256sums…
        curl-7.54.0.tar.gz ... Aprobado
        curl-7.54.0.tar.gz.asc ... Omitido
    ==> Verificando las firmas de las fuentes con gpg…
        curl-7.54.0.tar.gz ... HA FALLADO
    ==> ERROR: ¬°Una o m√°s firmas PGP no pudieron ser verificadas!
    ==> ERROR: Makepkg no ha podido compilar libcurl-openssl-1.0.
    ==> ¬ŅReiniciar la compilaci√≥n de libcurl-openssl-1.0? [s/N]
    

    Antergos Gnome - Lenovo G4070
    Antergos XFCE - Asus E-11
    Xubuntu 16.04.4 LTS - Dell D630
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc

  • This did the trick for me:

    yaourt -S --m-arg --skippgpcheck --noconfirm libopenssl-1.0-compat
    
    yaourt -S --m-arg --skippgpcheck --noconfirm libcurl-openssl-1.0
    
    yaourt -S spotify
    

    Antergos Gnome - Lenovo G4070
    Antergos XFCE - Asus E-11
    Xubuntu 16.04.4 LTS - Dell D630
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc

  • @woan Exelente, me funcion√≥, despu√©s de la actualizaci√≥n de Spotify, ya no ten√≠a acceso a el, pero con las keys problema resuelto

  • @Caiosama205 Thak you man! Here work!

Posts 9Views 5389
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.