• Can't Update System


    You will probably need more information. Ask away. This is what happens on my system. My initial reaction is to reinstall the whole system, but then, wasn’t I promised that I only ever had to install once?

    $ sudo pacman -Syu
    [sudo] password for wayne: 
    :: Synchronizing package databases...
     antergos is up to date     0.0   B  0.00B/s 00:00 [----------------------]   0%
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    
    error: failed to prepare transaction (could not satisfy dependencies)
    :: gnome-settings-daemon-redshift: installing gnome-desktop (1:3.24.1-1) breaks dependency 'gnome-desktop<1:3.24'
  • I am getting the same error with a different dependency reference. This is since upgrading the day before yesterday.

    error: failed to prepare transaction (could not satisfy dependencies)
    :: gstreamer0.10-good-plugins: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'
    
    
  • @shwaybotx

     ::`error: failed to prepare transaction (could not satisfy dependencies)
    :: gnome-settings-daemon-redshift: installing gnome-desktop (1:3.24.1-1) breaks dependency 'gnome-desktop<1:3.24'
    

    It seems that you ll have to do without gnome-settings-daemon-redshift for the time being👼

    @opalepatrick , check this out:
    https://forum.antergos.com/topic/6694/cannot-update-libsoup-due-to-gstreamer-good/2

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Can't Update System:

    @shwaybotx

     ::`error: failed to prepare transaction (could not satisfy dependencies)
    :: gnome-settings-daemon-redshift: installing gnome-desktop (1:3.24.1-1) breaks dependency 'gnome-desktop<1:3.24'
    

    It seems that you ll have to do without gnome-settings-daemon-redshift for the time being👼

    @opalepatrick , check this out:
    https://forum.antergos.com/topic/6694/cannot-update-libsoup-due-to-gstreamer-good/2

    Thank you. I could see that too. However, when I did a sudo pacman -R gnome-settings-daemon-redshift I was asked if I was sure I wanted to uninstall gnome 3. This seemed like an endless loop of dependencies and since I was in gnome 3 at the time I got frustrated.

    I took the extreme approach, which was remarkably painless and not very time consuming.

    What I did was reinstall Antergos but chose not to reformat /home … that kept all my settings in tact, even my rotating wallpaper for which I am so proud. My system had dozens of unnecessary DE’s like Plasma, KDE, Xfce, Cinnamon, ad infinitum, for testing purposes. I was asking for conflicts. Decided to go back to the KISS philosophy and start afresh.

system81 Posts 4Views 1042
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.