• Desktop doesn't start with dedicated GPU


    Hi,

    I just installed Antergos on a new computer while using the integrated GPU, installed the OS and then I inserted a GTX 1080Ti.
    After that I have not been able to get into the desktop environment. However, I do get a tty and I am able to use the computer through that.

    The interesting thing is that when connecting my monitor back to the integrated GPU, the computer boots fine into the OS.
    What I have tried:

    • Installing the nvidia-lts package (I am on the LTS kernel aswell)
    • Adding nomodeset to the GRUB_CMDLINE_LINUX_DEFAULT params list

    Before installing the nvidia drivers I got spammed with Nouveau errors both on boot and power off (same error repeating, didn’t have time to catch exactly what it said). After installing the drivers the error disappeared.

    I have attached two systemd log files, one for a successful boot using the intergrated GPU and one for a non successful boot and the grub config
    Below you can see two photos. One with the quiet param turned off, and one with it turned on. Common for the two is it complaining on some PCI-device. It seems to be the wifi, but the wifi works when booting on the intergrated GPU (and it shouldnt halt the boot?)

    Hope you guys have some tips on what I could do to get this working. Thanks!
    [0_1493060368620_logs.tar](Uploading 100%)
    Currently not able to upload in the post.
    The logs can be downloaded from dropbox here: link

    Quiet param

    No quiet param
    alt text

  • Update:
    When choosing Advanced Boot Options in Grub, and then manually choosing the lts kernel it boots fine. It shows about 30 seconds of black, backlit monitors (all three) before the desktop shows. I can live with that.

    But I chose the lts kernel when installing ,and yet the default option is not lts. How can I change this? I guess its a grub config issue?

  • If you have both kernels installed LTS is set to fallback thats the way it is the best ;)
    You can change this with grub-customizer by GUI App or by hand like this:
    Edit the file /etc/default/grub

    sudo nano /etc/default/grub
    

    change:
    GRUB_DEFAULT=0
    to
    GRUB_DEFAULT=saved

    save the file and then:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    This will save the last choosen entry for the next boot.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad Thanks! I’ll try that when I get home. :)
    Since the initial problem is fixed, I’ll go ahead and mark this as solved.

nvidia100 gpu11 dedicated2 Posts 4Views 251
Log in to reply