• pamac-manager authentication failed error


    Hi,

    Everytime i run pacmac-manager (not as root) and try to install a package from AUR, after pressing ‘Commit’ a window apperars showing only the message “Authentication failed”.

    I think its something broken after an update.

    There is no output on the terminal. System is up-to-date.
    Window manager is I3.

    Any help will be apreciated.
    Thanks

  • Authentication failed do you have gksu or similar installed? pamac needs to invoke authentification to install packages

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad Thanks,
    Now gksu is installed, but the problem persists :(
    After hitting “commit” button the error window appears.

  • and if you go on settings of pamac GUI? it ask for password?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad No, “Options button > Preferences” does nothing, no password prompt, no error message. The preferences window appears only if pamac is run with sudo.

  • @MrBtx pamac…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • i do not have a clue on I3 so may @fernandomaroto ? as i rememeber has experience with it?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @MrBtx Hi, under i3-wm none of the polkit and keyring are installed/loaded unless you configure it.
    First install them:
    sudo pacman -S polkit-gnome gnome-keyring

    Then set them to start in your i3-wm config file ~/.config/i3 adding the line below:

    exec --no-startup-id /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 & eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) &

    That will work, i had to do the same when i started using i3-wm.

    Cheers

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • The solution from fernandomaroto works and fixed it, solved.
    Thanks :)

pamac39 authentication9 aur34 update45 Posts 9Views 794
Log in to reply