• [SOLVED] gsettings does not work "libselinux.so.1" cannot open

    gsettings: “error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory”

    Whenever I run a command that interacts with gsettings (gsettings set org.gnome.desktop.interface show-battery-percentage true) or when I use ‘screenfetch’, I get the error stated above, along with screenfetch showing no themes. I noted that libselinux was apart of the AUR, and if I install and use that, gsettings runs in a ‘memory mode’ and doesn’t save my settings. It also would not make sense for gsettings to require something from the AUR.

    0_1493021544199_Screenshot from 2017-04-24 01-12-02.png

    Things I’ve Tried:

    1. Google. All I can find are a bunch of unanswered bug reports, ubuntu support that doesn’t seem to anything similar either.

    2. Using libselinux off the AUR, but that only created a new problem with gsettings using a ‘memory’ backend and not savivng my settings

    3. install dconf-editor. I’m not sure if this was supposed to be pre-installed or not, I can’t remember because other OS’s have, but either way, I installed this and this is what it shows, which seems kinda bare-bones that what I remember seeing, but I’m no expert.

    0_1493022007812_Screenshot from 2017-04-24 01-19-55.png

    I’ve done a fresh install of antergos yesterday, and most of the things I’ve done so far are putting things into ~/.themes, ncurses5-compat-libs for MATLAB, tilda for the sweet drop down terminal, anaconda for sweet python packages. I feel though I noticed this somewhat early on before much was installed as one of the first things i do is type ‘gsettings set org.gnome.desktop.interface show-battery-percentage true’.

    EDIT: Solved it. I installled anaconda, which is something for python packages and what not, that I got because of some programming event I went to. When installing it on linux, it asked if it wanted to change the path of my .bashrc, but that messed up the path that gsettings saw, and it stopped working. Once I deleted the line anaconda added, it worked again!

  • Do you using a selinux enabled Kernel?
    If not you should misinstall something related to selinux

  • @Metropolis Ive also put a journalctl log here:

    since I couldn’t figure out how to add the .tar to the post.

    Anyway around line 1220 is where gnome-shell starts to look a little suspicious, but I am unsure.

  • @joekamprad In all honesty, I am unsure of how I could have a kernel any different than the one that is given to me when I install antergos. I don’t choose any LTS kernal support, and in I don’t remember having gsettings issues with antergos before. I have not installed any special kernels or anything, as I’ve just installed antergos a day ago from the install media. I have added a journalctl log to the post if you wanted to examine that for any information.

  • …something related to selinux, what maybe needed a kernel feature from a selinux enabled kernel to be more specific…

  • pacman -Fo /usr/lib/libselinux.so.1

    outputs nothing?

  • ldd -v /usr/bin/gsettings > gsettings.txt && gedit gsettings.txt

    and search for selinux

  • pacman -Fo /usr/lib/libselinux.so.1

    Indeed this outputs nothing.

    ldd -v /usr/bin/gsettings > gsettings.txt && gedit gsettings.txt

    selinux is not anywhere inside of this file. I’m not sure if it is supposed to be there, and how a typical antergos install would deviate from the norm.

  • No i do not have this iselinux nside the gsettings bin also…

  • 0_1493040559538_Screenshot from 2017-04-24 06-28-37.png
    I am unsure if this is related, but anytime I open firefox, this error occurs. I am beginning to wonder if something even deeper with the gnome shell as a whole is messed up.

  • This is may caused by the way extensions are installed, to be more clear the two ways, you can install them from repo/Aur or do install them directly within the gnome-shell.
    That ones installed from repo/AUR can not be updated by the g-s-i

gsettings3 libselinux.so.11 Posts 11Views 3136
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.