• PCIe bus error, antergos not booting


    I have ASUS x556ub laptop with Nvidia geforce 940m graphics card.

    I have successfully installed antergos from cnchi installer, I used “erase disk and install antergos” option, and antergos installed successfully without any error. But , after restarting,
    alt text
    this menu comes, then i choice ‘Antergos Linux’ hit enter, and a black screen appears showing continuous error messages= (I found them from live mode system log)

    11:50:56 kernel: pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
    11:50:56 kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
    11:50:56 kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
    11:50:56 kernel: pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
    11:50:56 kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
    11:50:56 kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
    11:50:56 kernel: pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
    11:50:56 kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
    11:50:56 kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
    11:50:56 kernel: pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
    11:50:56 kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
    11:50:56 kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
    11:50:56 kernel: pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
    11:50:56 kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
    11:50:56 kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
    

    and so on…

    and i can do nothing without force shutdown.
    Now what can i do?

    Here is a sceenshot of gparted from live USB
    alt text

    If you need more information inform me.
    Here is a screenshot of gparted from live USB:
    http://prnt.sc/f03iyy

  • what gives you:

    lspci | grep 00:1c.5
    

    ???

    [updates once a week] = [90% less problems]
    my#repo
    my-blog#k
    how to add system logs
    i3-°-xfce

  • @joekamprad Where I have to run that command?

    In live mode, It gives:

    00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
    
  • This is the device causing that error you got…

    [updates once a week] = [90% less problems]
    my#repo
    my-blog#k
    how to add system logs
    i3-°-xfce

  • @joekamprad
    ok, but is it possible to solve this issue?
    I am actually trying for about 3 days, but still I am undone.

  • putting pci=nomsi to kernel parameter at bootup should solve this:

    On bootup press “e” button and put the parameter right after quiet
    Bild Text
    Boot up with it by pressing [F10] or [ctrg+X]

    If this is working >>>
    make it permanent:

    sudo nano /etc/default/grub
    

    put the pci=nomsi to this line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi .....XXXXX
    
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    reboot
    

    [updates once a week] = [90% less problems]
    my#repo
    my-blog#k
    how to add system logs
    i3-°-xfce

  • @joekamprad
    Yes, It’s working, but for non-graphical boot only (ctrl+alt+f2). I can successfully login in non-graphical boot.
    And yes, the errors are disappeared. But antergos not booting 😞 It is getting stuck in a black screen showing some errors only.

    starting version 232
    AntergosRoot: clean, 275721/60514304 files, 6332811/242054912 blocks
    [    8.413037] tpm_crb MSFT0101:00 can't request region for resource [mem 0xfed
    [    9.323786] Bluetooth: hci0: Failed to load rtl_bt/rt18723b_config.bin
    
  • you can try o install nvidia drivers:

    sudo pacman -S nvidia-installer
    sudo nvidia-installer -f
    sudo systemctl reboot
    

    You can try changing the DM:

    sudo pacman -S gdm
    sudo systemctl -f disable lightdm
    sudo systemctl -f enable gdm
    sudo systemctl reboot
    

    [updates once a week] = [90% less problems]
    my#repo
    my-blog#k
    how to add system logs
    i3-°-xfce

  • @joekamprad
    I tried the second option.

    sudo pacman -S gdm
    sudo systemctl -f disable lightdm
    sudo systemctl -f enable gdm
    sudo systemctl reboot

    It successfully booted. But the desktop is blank, and full blue.
    alt text

  • looks nice 😉

    looks like the gnome-classic-mode?

    [updates once a week] = [90% less problems]
    my#repo
    my-blog#k
    how to add system logs
    i3-°-xfce

  • Bild Text
    try to logout from session and use GNOME or GNOME in Xorg …

    [updates once a week] = [90% less problems]
    my#repo
    my-blog#k
    how to add system logs
    i3-°-xfce

  • @joekamprad
    Ohh 😆
    Yes ! It worked ! 😃
    Thanks a lot.

  • You are welcome !

    [updates once a week] = [90% less problems]
    my#repo
    my-blog#k
    how to add system logs
    i3-°-xfce

error220 booting31 pcie3 bus2 Posts 13Views 1538
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.