• After reboot stuck at grub


    hi,

    I tried to install virtualbox via pamac, and wasn’t able to load any vm, installed several related packages to no avail and thought a reboot might help. Rebooted properly but since then I can’t boot into my antergos installation. It gets stuck here: ![0_1492916421534_IMG_20170423_054644.jpg](Uploading 100%) 0_1492916700069_IMG_20170423_054644.jpg

    What do I need to do? Reinstall grub? How did I cause this?

  • several packages is not very detailed…
    And installing virtualbox needs only:

    sudo pacman -S virtualbox virtualbox-host-modules-arch virtualbox-guest-iso
    sudo  modprobe vboxdrv
    

    With this you should be fine for using it.

    If your boot problem is caused by wrongly installed packages you need to uninstall thouse from booting with LiveIso and chrooting into your HD-System.
    I can guide you but i need to know about if you are booting with Bios or EFI

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi, thanks for the reply!

    I’m booting with Bios.

    regarding VB, firstly I just installed the package via GUI, it seemed fine and installed successfully but I got an error while trying to load the VM I created, (1908) suggesting I should run /sbin/vboxconfig as root. I tried that got an error, IIRC “command not found”, so I started googling and various posts suggested installing various packages (headers, modules, dkms or arch etc) and I kept trying to install and see if it helps, to no avail.

    coming from windows, I figured I’d try a restart and see if something changes, the system worked fine. I restarted via the GUI and then got stuck- after verifying dmi pool data it just says “GRUB” and nothing else.

    not sure what happend there, every package i installed was related to VB and from the repository.

  • you can try, may simple reinstalling grub helps:

    bott with LiveIso open a terminal

    sudo su
    fdisk -l
    
    /dev/sdX1  *         2048    524287    522240   255M 83 Linux
    /dev/sdX2          524288 222470143 221945856 105,9G 83 Linux
    /dev/sdX3       222470144 234441647  11971504   5,7G  f W95 Erw. (LBA)
    /dev/sdX5       222472192 234441647  11969456   5,7G 82 Linux Swap / Solaris
    

    X=a/b/c/d depending on your system

    mount /dev/sdX2 /mnt
    mount /dev/sdX1 /mnt/boot
    arch-chroot /mnt
    
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=i386-pc /dev/sdx
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Encountered errors, it let me mount and chroot, but had problems with grub…

    Antergos is installed on sdb (a GPT disk), sdb4 is root and sdb1 is /boot.

    Windows is installed on another drive, to minimize headache…

    Here’s everything I’ve done:
    https://pastebin.com/HbPpP8jT

  • Device          Start        End    Sectors  Size Type
    /dev/sdb1      264192    2312191    2048000 1000M EFI System
    /dev/sdb2     2312192 5759129599 5756817408  2.7T Microsoft basic data
    /dev/sdb3  5830809600 5852338175   21528576 10.3G Linux filesystem
    /dev/sdb4  5759129600 5830809599   71680000 34.2G Linux filesystem
    /dev/sdb5  5852338176 5860531021    8192846  3.9G Linux swap
    

    not Bios-Boot it is EFI-boot!
    So reboot to Live-Iso and do like this:

    sudo su
    mount /dev/sdb3 /mnt
    mount /dev/sdb1 /mnt/boot/efi
    arch-chroot /mnt
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Antergos-grub
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi,
    I created this partition as instructed in the ArchWiki for large GPT disks, otherwise grub won’t recognize the partitions beyond a 2+ TB NTFS data partition. the PC itself is 7 years old and uses bios, not UEFI.
    If I misunderstood the definition of EFI, I apologise for the confusion.

    Either way, I rebooted and tried what you suggested, it prompts another error: failed to get cannonical path of ‘/boot/efi’

    Log: https://pastebin.com/QZL53c4m

  • EFI System is what it say for /dev/sdb this should not be mounted under /boot
    because you do not have a extra /boot partition. it is inside / (root).
    if you can check please:

    sudo su
    mount /dev/sdb3 /mnt
    arch-chroot /mnt
    
    
    cd /boot
    ls
    

    can you give me the URL: ArchWiki for large GPT disks,

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi,

    I entered what you suggested to the terminal, no errors but nothing happened.

    Regarding the wiki page, I think I misspoke, it’s been a while since I did it.

    The problem I had was my Linux partitions came after a large NTFS one on a 3TB GPT disk and GRUB wouldn’t boot from them after install. after quite a bit of digging I found a post (I think in superuser forums) which suggested grub cannot see a boot partition if another large partition comes before it. So I read a bit in the wiki and in the GRUB page, there was a reference to a GPT/BIOS setup.

    Here: https://wiki.archlinux.org/index.php/GRUB

    Under “Bios systems” it says:
    On a BIOS/GPT configuration a BIOS boot partition is required. GRUB embeds its core.img into this partition.
    It also states it needs to be within the first 2 TB. And that some systems require at least one bootable partition which isn’t ext, I collected data a bit here and a bit there.

    I created a 1 MiB partition as suggested but it still didn’t help, so I kept digging until I found another I post which suggested moving the boot partition to the beginning of the disk. So I did (took about 26 hours) and created a bootable EFI fat32 boot partition using the instructions i found in a related page in the wiki, then and only then it finally booted successfully​.

  • sudo su
    mount /dev/sdb3 /mnt
    arch-chroot /mnt
    
    cd /boot
    ls
    

    is what i need to help you…
    If you do not remember how you install Grub before…
    As i read there it is kind of a trick and you just create this BIOS boot partition at the first place on the hd, and do a normal MBR install of Grub on the hd then…
    If so i am not shure of may you need to recreate the BIOS boot partition, and then do install grub to the MBR again:

    grub-install --target=i386-pc /dev/sdb
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi,

    Before it didn’t say anything when I chrooted and typed what you posted.
    When I googled the errors I got I found a post that mentioned that the boot partition must have a grub-boot flag, so I changed it via Gparted and tried installing again. This time mkconfig still trew the same errors but I managed to install grub via grub-install. I rebooted and this time I got to grub rescue, changing the flag back to boot didn’t help.
    Frustrated, I booted into livecd, formatted the boot partition and tried to install again.
    Still threw the same errors… Now when I type what you posted it just says “grub”.

reboot11 stuck28 grub79 Posts 11Views 872
Log in to reply