• Unable to connect to Wifi at college.

    Hello there!

    So, ever since I installed Antergos on my laptop, I can’t connect to the wifi at my college. I’ve tried some methods as cloning the macaddress with macchanger but had no luck.

    The strange thing is that the only wifi I can’t connect is there. I have registered the all the macaddress I used in their system but had no change. And as a noob on linux and arch based distros, I don’t know exactly what to do.

    Someone has any clue on how to fix this?

    PS: A friend also uses a arc based distro called Apricity and he has the same problem.

    Let me know if you need any prints or logs so I can post it here for help.

    Thank you in advance!

  • iw dev

    will give you the name of your interface, right after the word interface

    sudo iw dev *interface* scan | less

    you can scan and search for the SSID of the Accesspoint you want to connect…
    And all possible information around the Accesspoint.

  • What’s your wifi card?
    If you don’t know you can run:

    lspci | grep -i wireless

    And also if you can find out what your friend’s wifi card model and the school wireless router model too.
    A good starting point would be searching for issues others have had with the same hardware (if you haven’t already done that)

    Also try connecting once and then immediately post the output of


    here, it’ll probably help.

  • @joekamprad I typed the command you told me, and here’s the output:

    BSS c4:a8:1d:94:69:78(on wlp3s0)
            TSF: 2696325238 usec (0d, 00:44:56)
            freq: 2422
            beacon interval: 100 TUs
            capability: ESS ShortPreamble (0x0021)
            signal: -45.00 dBm
            last seen: 606 ms ago
            Information elements from Probe Response frame:
            SSID: FUMEC
            Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0 9.0 12.0 18.0 
            DS Parameter set: channel 3
            Country: US     Environment: Indoor/Outdoor
                    Channels [1 - 11] @ 40 dBm
            ERP: <no flags>
            Extended supported rates: 24.0 36.0 48.0 54.0 
            HT capabilities:
                    Capabilities: 0x1ad
                            RX LDPC
                            SM Power Save disabled
                            RX HT20 SGI
                            TX STBC
                            RX STBC 1-stream
                            Max AMSDU length: 3839 bytes
                            No DSSS/CCK HT40
                    Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                    Minimum RX AMPDU time spacing: No restriction (0x00)
                    HT TX/RX MCS rate indexes supported: 0-15
            HT operation:
                     * primary channel: 3
                     * secondary channel offset: no secondary
                     * STA channel width: 20 MHz
                     * RIFS: 0
                     * HT protection: non-HT mixed
                     * non-GF present: 1
                     * OBSS non-GF present: 1
                     * dual beacon: 0
                     * dual CTS protection: 0
                     * STBC beacon: 0
                     * L-SIG TXOP Prot: 0
                     * PCO active: 0
                     * PCO phase: 0
    	Overlapping BSS scan params:
                     * passive dwell: 20 TUs
                     * active dwell: 10 TUs
                     * channel width trigger scan interval: 300 s
                     * scan passive total per channel: 200 TUs
                     * scan active total per channel: 20 TUs
                     * BSS width channel transition delay factor: 5
                     * OBSS Scan Activity Threshold: 0.25 %
            Extended capabilities: HT Information Exchange Supported, 6
            WMM:     * Parameter version 1
                     * u-APSD
                     * BE: CW 15-1023, AIFSN 3
                     * BK: CW 15-1023, AIFSN 7
                     * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
                     * VO: CW 3-7, AIFSN 2, TXOP 1504 usec

    @gavinfernandes2012 Here’s the output for the commands you informed:

    [  169.427545] wlp3s0: deauthenticating from c4:a8:1d:94:69:78 by local choice (Reason: 3=DEAUTH_LEAVING)
    [  684.611832] wlp3s0: authenticate with c4:a8:1d:94:69:78
    [  684.624034] wlp3s0: send auth to c4:a8:1d:94:69:78 (try 1/3)
    [  684.626286] wlp3s0: authenticated
    [  684.627476] wlp3s0: associate with c4:a8:1d:94:69:78 (try 1/3)
    [  684.631591] wlp3s0: RX AssocResp from c4:a8:1d:94:69:78 (capab=0x21 status=0 aid=12)
    [  684.631674] wlp3s0: associated

    My Card: 03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

  • @PsykoLucas
    OK your wifi card seems perfect, its even Ubuntu certified so it shouldn’t be the problem.
    The dmesg output looks completely normal to me too, (I just double checked to what i get when I successfully connect to my WiFi).

    1. What did you do to find your MAC address? Any command or anything? Preferably detail what you did so we can be sure you got the right MAC.
    2. Do you know of anyone else that has been able to connect using any linux distribution?
    3. When you say you can’t connect, do you mean you don’t have internet? or do you mean the wifi doesn’t connect at all and you don’t have network access?

    One more command for diagnosis:


    Also see the suggestions in this thread: http://www.tomshardware.com/answers/id-2557750/internet-connection-mac-address-filtering-enabled.html
    They might help if you didn’t already.

  • @gavinfernandes2012
    1 - When I first started using linux, I used ifconfig to find my MAC address, then when I installed Antergos and couldn’t connect to college wifi, I tried cloning the MAC with macchanger, but since it didn’t work I returned the MAC to original.

    2 - Yes, myself included, I’ve used Ubuntu and Debian before and had no problem connecting there.

    3 - It tries to connect, stays a while like that, and then it stops and doesn’t connect.

    I asked a professor who knows a couple things about Linux, and he thinks it’s probably a security measure from Arch, since the wifi connection in my college is poorly configured and might be considered unsafe. Do you think it’s a possibility?

    PS: Unfortunately I couldn’t bring my laptop today so i won’t be able to type in that last command you asked me to, but tomorrow i make sure to bring it and type that if these information I just gave doesn’t help!

    EDIT: I think it’s important to say that to be able to connect to the college wifi, one should register the device’s MAC Address in their system. I have my MAC Address registered, and so far I was able to connect with no problem. Using Windows and/or Linux, I have used Ubuntu, Kali, Debian and none of them had this problem so I’m don’t really understand what might be the cause.

    1. Are you positive you didn’t accidentally use your Ethernet’s MAC address? (Idk if you know but I think the new naming scheme for wireless devices gives them names like wlp3s0, that confused me when I came to arch from Ubuntu)
    2. Ask your professor or find out yourself whether the network is WPA2, WPA or WEP? If its WPA ask if it uses TKIP or AES or does it support both? That’ll give us a good starting point if its a security problem.
    3. Run pacman -Q wpa_supplicant , it should tell us that wpa_supplicant is installed, I assume the Cnchi installer installed it when you installed Antergos, I’m assuming you used Cnchi.
    4. Are you using a GUI Network manager? Which one? If you are you can install dialog: pacman -S dialog and run wifi-menu and connect using it, just to rule out a problem with your network manager (which is very unlikely but just in case)
  • @gavinfernandes2012 Hello there!

    Sorry it took so long for me to answer. I was busy with somethings.

    1 - Yes, I’m positive i’m using the wireless MAC address.

    2 - I asked him and he said that in the school’s case, it’s open.

    3 - Yes, i used Cnchi to install Antergos. I ran the command and returned this: wpa_supplicant 1:2.6-5 so it’s installed.

    4 - I installed dialog and today when I get there I try to connect using wifi-menu.

  • Ohh and one more thing can you get the dmesg log just after you’ve connected and then been disconnected, for your normal gui network manager, also can you post the output of journalctl -f /usr/bin/NetworkManager .

  • Hello! Again… sorry it took me so long to answer.

    BUT! Fortunately, I come with good news… Today I found a solution for the problem and managed to connect to my university’s wifi.

    I just reinstalled the networkmanager and it worked. Apparently it was corrupted or something. But now it works just fine. And it didn’t affect the connection in other networks too, so i’m okay now!

wifi152 unable76 connect36 college2 Posts 10Views 3018
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.