• need help: error loading shared library libssl.so.1.1


    Hi,

    So im facing a problem with qBittorrent in that i cant open it, and it gives an error saying it cant load shared library libssl.so.1.1. , cannot open shared object, no such file or directory.

    i can see libssl.so.1.1 in /usr/lib/libssl.so

    i tried reinstalling openssl, have not found any other solution as yet, some people have created a symlink to libssl.so.1.1 but its said that thats not the right way to fix the problem, so im out of ideas…

    any suggestions on how i could fix this problem. im using i3wm and arch mainline kernel

    Thanks for your help!
    K

  • openssl 1.0.2.k-1 actual Version
    /usr/lib/libssl.so.1.0.0 actual libs

    Version 1.1 is not already in repo it is in testing till it reach the repo
    Do you install qbittorent from community or testing?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad no, ive had qbittorrent installed since forever, and i got it from the stable repos, i dont have testing repos enabled, maybe i got libssl.so.1.1. as a dependency of some <program>that i installed from yaourt?

  • do:

    pacman -Qs openssl
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    i get openssl 1.0.2.k-1

    and i checked /usr/lib again, my bad, it shows libssl.so.1.0.0

    i wonder why qbittorrent is trying to load libssl.so.1.1

  • strange i just install it and i can open and run it from menu (GNOME) but i get the same error when starting inside terminal

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • you can try also deluge it is very similar to qbittorrent…
    linking the lib is never a good idea, because you will forget about it and problems will come out of this…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    yeah that is strange indeed, i will take a look at deluge or some other client, the only reason ive been using qbittorrent is because it has a built in search engine.
    thanks for your help! marking this as solved since it’s specific to qbittorrent.

  • Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 349, in _on_reactor_start
        client.start_classic_mode()
      File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 559, in start_classic_mode
        self._daemon_proxy = DaemonClassicProxy(self.__event_handlers)
      File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 432, in __init__
        self.__daemon = deluge.core.daemon.Daemon(classic=True)
      File "/usr/lib/python2.7/site-packages/deluge/core/daemon.py", line 144, in __init__
        from deluge.core.core import Core
      File "/usr/lib/python2.7/site-packages/deluge/core/core.py", line 38, in <module>
        from deluge._libtorrent import lt
      File "/usr/lib/python2.7/site-packages/deluge/_libtorrent.py", line 59, in <module>
        import libtorrent as lt
    ImportError: libssl.so.1.1: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
    

    From deluge…

    So i think this is caused by libtorrent-rasterbar then…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    yes youre probably right, and libtorrent-rasterbar was last updated on 04/22, which could probably be when the error started showing, because i wasnt getting this error a couple days back…

  • an update to libtorrent-rasterbar just came in, all works well now… no error in the terminal anymore. :)

  • dev was maybe wrongly push the next version before…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

error213 loading20 shared7 library1 Posts 12Views 1880
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.