• Live USB and no wifi


    Hi everyone,

    I am getting ready to install Antergos for the very first time but have a wee problem with wifi - theres no option for wifi at all in the network manager.

    The laptop I want to install Antergos on is currently running Manjaro and there was no problem with wifi at all.

    Hardware configuration under Manjaro is showing BCM43225 (network-broadcom-wl)

    Is there anything I can do to make it work with Live USB so I can proceed with the installation?

    Thanks,
    Mac

  • @m4g1c

    Could you connect to the wired or ethernet network? Then, when connected, download the package:

    yaourt -S broadcom-wl-dkms
    

    That is all

    Autodidacta en la VIDA …y en Linux, también.

  • From ArchWiki:
    brcm80211
    The kernel contains two built-in open-source drivers: brcmfmac for native FullMAC and brcmsmac for mac80211-based SoftMAC. They should be automatically loaded when booting.
    Note:
    brcmfmac supports newer chipsets, and supports AP mode, P2P mode, or hardware encryption.
    brcmsmac only supports old chipsets like BCM4313, BCM43224, BCM43225.

    It is supported by the kernel.

    ip link
    

    will give you the detected devices.

    sudo ip link set interface up
    

    will bring it up, interface needs to be the devicename of your card you get with the former command…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • You can also do

    ip link
    

    Write what you throw here

    Autodidacta en la VIDA …y en Linux, también.

  • @joekamprad

    I apologize, we post almost at the same time, if my answer does not seem right, erase it without problems :)

    Autodidacta en la VIDA …y en Linux, también.

  • @judd i write the same before so we have the same opinion ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad said in Live USB and no wifi:

    @judd i write the same before so we have the same opinion ;)

    Have the same opinion, it’s very good :);)

    Autodidacta en la VIDA …y en Linux, también.

  • Thank you guys for quick replay!

    ip link gives me this:

    [[email protected] ~]$ ip link
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
        link/ether 1c:75:08:4a:80:dd brd ff:ff:ff:ff:ff:ff
    [[email protected] ~]$ 
    

    I am pretty new to linux so not exactly sure what to put as interace. I’ve tried enp1s0 but that didn’t work.

  • @m4g1c

    mmm what said ???

    $ iwconfig
    
    

    https://wiki.archlinux.org/index.php/Wireless_network_configuration

    Autodidacta en la VIDA …y en Linux, también.

  • @judd

    [[email protected] ~]$ iwconfig
    enp1s0    no wireless extensions.
    
    lo        no wireless extensions.
    
    [[email protected] ~]$
    
  • so seems like wifi is not detected.
    try to enable the driver manual:

    sudo modprobe brcmsmac
    

    and see if your wifi is enabled then again with:

    ip link
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad that worked perfectly. Thank you for taking your time to help with my problem, you’re a rockstar!

  • @m4g1c :blush:
    Nice to see that it has worked, BROADCOM has a very insufficient Linux driver support. You were lucky it was an older chipset
    Hope your installation went fine, and wifi still working after reboot then…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad
    Took longer then it should but its totally my fault or should I say weather and problems with network…

    Long story short - it’s done :) and thanks to you wifi works without a problem!

wifi74 live-usb3 Posts 14Views 568
Log in to reply