• \[SOLVED\] gnome 3.12 - my screen wont blank


    I upgraded to gnome 3.12 and am totally loving it so far but for some reason my screen will not go black after the computer has sat idle for a while. I have searched through the settings and even gnome tweak to find a way to turn it on and in power settings I have blank screen set to five minutes but it still will not do this. Am I missing a setting somewhere? Any help would be appreciative.

  • I upgraded to gnome 3.12 and am totally loving it so far but for some reason my screen will not go black after the computer has sat idle for a while. I have searched through the settings and even gnome tweak to find a way to turn it on and in power settings I have blank screen set to five minutes but it still will not do this. Am I missing a setting somewhere? Any help would be appreciative.

  • Hi,

    Install the xscreensaver package to correct this. It will be fixed in the upcoming release.

    Cheers!

  • Okay I’ve installed it and configured it the way I want and it’s working. How do I get it to start at boot since there seems to be no startup applications app? Do I create an .xinitrc file to do that one thing or is there a systemctl call?

  • You should be able to open the startup applications app by running “gnome-session-properties”. (Unless the GNOME devs removed it) Another method is creating a file in your autostart directory containing

    \#!/bin/bash  
    /usr/bin/xscreensaver -no-splash &  
    exit 0;
    

    Save it to ~/.config/autostart and make it executable.

    Cheers!

  • @“lots.0.logs”:2y77xch3 said:

    You should be able to open the startup applications app by running “gnome-session-properties”. (Unless the GNOME devs removed it) Another method is creating a file in your autostart directory containing

    \#!/bin/bash  
    > /usr/bin/xscreensaver -no-splash &  
    > exit 0;
    

    Save it to ~/.config/autostart and make it executable.

    Cheers![/quote:2y77xch3]

    I have two scripts I want to start at startup:

    #!/bin/bash

    xrandr --output HDMI-0 --set underscan on
    xrandr --output HDMI-0 --set “underscan hborder” 48 --set “underscan vborder” 26

    and

    #!/bin/bash
    /usr/bin/nautilus &
    exit 0;

    I put both those as per your instruction but they don’t startup, they work fine in a terminal.

    "An it harm none, do what thou wilt"

  • Are they marked executable?

  • @“lots.0.logs”:254l6x3k said:

    Are they marked executable?[/quote:254l6x3k]

    yep, btw I had to make the autostart folder, it wasn’t there to begin with.

    "An it harm none, do what thou wilt"

  • It works as per these instructions though:

    [url:12vztk88]http://linuxandfriends.com/how-to-add-startup-programs-in-gnome-3/[/url:12vztk88]

    "An it harm none, do what thou wilt"

  • Evidently gnome-session-properties was removed from 3.12 by the devs. It’s not installed on my system and pacman doesn’t find it when I try to install it (yes I installed the gnome extras package). I got xscreensaver working and starting automatically via Pednick’s suggestion and everything is working great. Thanks lots.O.logs and Pednick for the help

  • don’t forget to edit the subject solved if your issue has been resolved

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • @“MacWillie”:26csxdl2 said:

    Evidently gnome-session-properties was removed from 3.12 by the devs. It’s not installed on my system and pacman doesn’t find it when I try to install it (yes I installed the gnome extras package). I got xscreensaver working and starting automatically via Pednick’s suggestion and everything is working great. Thanks lots.O.logs and Pednick for the help

    No problem, glad to help.

    "An it harm none, do what thou wilt"

  • I installed the newest version Antergos a few weeks ago, and I also have the problem that my screen won’t blank, which is quite annoying, since I already set the “Blank screen” option in the Power section of Gnome settings to “3 minutes”. Changing that value is correctly changing the gnome setting, since “[i:1vkr0wqb]gsettings get org.gnome.desktop.session idle-delay[/i:1vkr0wqb]” changes when I change that setting.

    I git cloned git://git.gnome.org/gnome-settings-daemon, and when I try to run the [i:1vkr0wqb]test.py[/i:1vkr0wqb] script, I get this:


    [335575.135] (II) LoadModule: “dummy”
    [335575.135] (WW) Warning, couldn’t open module dummy
    [335575.135] (II) UnloadModule: “dummy”
    [335575.135] (II) Unloading dummy
    [335575.135] (EE) Failed to load module “dummy” (module does not exist, 0)
    [335575.135] (EE) No drivers available.
    [335575.135] (EE)
    Fatal server error:
    [335575.135] (EE) no screens found(EE)
    [335575.135] (EE)
    Please consult the The X.Org Foundation support
    at [http://wiki.x.org][1]">[http://wiki.x.org][2]
    for help.

    Arch’s wiki ([xorg Monitor_settings[/url:1vkr0wqb] and [Setting_up_DPMS_in_X[/url:1vkr0wqb]) says that Xorg should auto-configure, but this page [http://www.x.org/wiki/ConfigurationHelp/][5] says that if “[i:1vkr0wqb]X -configure[/i:1vkr0wqb]” was used, there should be a “/root/xorg.conf.new” file, but that doesn’t exist, so I’m not sure if Xorg is currently being auto-configured or not.

    I am currently using “xset 0 0 180”, but since this is not using “org.gnome.desktop.session idle-delay”, it’s just a hack and doesn’t fix whatever is the underlying issue.][4]][3]

    [1]: <a href=
    [2]: http://wiki.x.org
    [3]: https://wiki.archlinux.org/index.php/xorg#Monitor_settings:1vkr0wqb
    [4]: https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling#Setting_up_DPMS_in_X:1vkr0wqb
    [5]: http://www.x.org/wiki/ConfigurationHelp/

  • I changed to GDM and blanking works perfectly.

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • With the release of 3.12 the Gnome devs moved gnome-screensaver code directly into GDM and killed the package. They did not create a proper API for other desktop managers and screensavers to be able to provide the same experience as GDM. Obviously, they want all gnome users to use GDM. We are working on adding the most important functions that are missing. Until that is complete we have included xscreensaver for screen blanking and a custom screenlocking extension that integrates with lightdm. See the link below for info on adjusting your screen blanking and other screensaver settings. Please let me know if you have any questions.

    Best Regards,
    Dustin

    [https://wiki.archlinux.org/index.php/XScreenSaver][0]">[https://wiki.archlinux.org/index.php/XScreenSaver][1]

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/XScreenSaver

  • " We are working on adding the most important functions that are missing".
    Please, do let us know when this is done!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

Posts 16Views 2775
Log in to reply