• Unable to boot to LiveCD (USB) under UEFI


    Hello, I want to try out Antergos but I am unable to boot into the live USB. No matter the option I choose I come to a black screen with two messages:

    0.223565 efi: requested map not found
    0.223570 efi: Failed to lookup EFI memory descriptor for 0x00000000df14407
    

    I have tried to recreate the USB multiple time using different methods but they all produce the same error.

  • Have you checked out your BIOS settings? Occasionally that is the problem.
    Would you also be able to tell me how far into the boot you are able to get? I’m assuming it is just a black screen with the error, but I would like to be sure.
    You can also check that it is booting under the boot menu.

  • @moredoor I have checked the BIOS settings before, I have disabled secure boot and the likes. This is how far I get:

    1. Turn on Computer
    2. Boot to USB device
    3. USB Boot Loader apprears
    4. Select the default choice
    5. Black screen with error above

    After about 1 min the screen goes completely black and I have to reboot my machine. I tried the same process with the Nvidia fallback, the No-gui fallback, with no change in results.

  • @zigithen You could always check the bootable devices. It looks like your computer is at least able to see that there is a device, which is a good sign. You can go into your BIOS and create a different boot option (with USB plugged in) and select the files from there. There should be something called EFI, and if you boot from that it might solve your problem.
    How did you go about making the live USB? (Just curious. UNetBootIn doesn’t work for Antergos, and I found that out the hard way.)

  • @moredoor When I go to the boot selection screen in my BIOS I make sure to choose the UEFI version of my USB drive instead of the legacy boot option.

    I made my live USB three ways,

    1. USBWriter for Windows
    2. Rufus for Windows
    3. sudo dd bs=4M if=/path/to/antergos-x86_64.iso of=/dev/sdX && sync from Mac OSX

    All three ways produced the same results.
    (Thank you for taking your time with me by the way)

  • @zigithen It is not a problem!
    When you see boot options, is one of them Antergos_grub?
    Alright, so I made a liveUSB. The file it boots from is

    /EFI/BOOT/BOOTX64.EFI
    

    If that is not what you are getting, you could try and change it. (just add a new boot option and make sure for the file system list to select the USB option. For example, mine is

    PciRoot(0x0)/Pci(0x1D.0x0)/USB
    

    It’s longer than that but you get the picture.
    The file name can just be found under the EFI folder.
    Sorry it took so long t get back to you! Hopefully this helps :)

  • @moredoor This might be a little out of my scope of understanding, but I do find the file you mentioned bootx64.efi. Also I do not have an option called Antergos_grub, I have the following:

    1. Antergos x86_64
    2. Antergos x86_64 (Non-Graphical Fallback)
    3. Antergos x86_64 (NVIDIA Fallback)
    4. UEFI Shell x86_64 v1
    5. UEFI Shell x86_64 v2

    I wouldn’t know how to add another boot option to this list. Though I can try to find something on it.

    (Side Note: I will be going away for about 2 weeks, starting today, so my replies from now may be heavily delayed)

  • @zigithen No problem :) I don’t know what kind of computer you have, so the BIOS settings might be different than mine. I have a DELL, so if you have one as well, I can help with that. Otherwise I’ll need some time to learn other BIOSes.
    ALSO: I’ve been looking more into ways to make live USBs and found that when using Rufus, you need to select ‘GPT partition scheme for UEFI’ after selecting the .iso file. Otherwise it will mess with the partition table and will not boot (kind of an issue).

unable33 usb55 boot150 livecd7 Posts 8Views 564
Log in to reply