• Black Screen after GRUB


    Hi all,
    let me start by thanking in advance for any solution, tips or tricks for this issue that`s been driving me crazy for the last 3 days.
    I installed antergos on a late 2009 mac mini and the installation ran without any problem, the issue is that when I boot the screen just goes black after the GRUB prompt. In fact there is the little ‘low line’ on the top left and nothing else.
    This is the line (I borrowed the pic from another post):
    alt text

    I already tried a couple of things without success, and I know I cannot install the nvidia drivers because after that I get lots of errors like CPU stuck and so on…

    dmesg here: pastebin

    lspci:

    00:00.0 Host bridge: NVIDIA Corporation MCP79 Host Bridge (rev b1)
    00:00.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
    00:03.0 ISA bridge: NVIDIA Corporation MCP79 LPC Bridge (rev b2)
    00:03.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
    00:03.2 SMBus: NVIDIA Corporation MCP79 SMBus (rev b1)
    00:03.3 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
    00:03.4 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
    00:03.5 Co-processor: NVIDIA Corporation MCP79 Co-processor (rev b1)
    00:04.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
    00:04.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
    00:06.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
    00:06.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
    00:08.0 Audio device: NVIDIA Corporation MCP79 High Definition Audio (rev b1)
    00:09.0 PCI bridge: NVIDIA Corporation MCP79 PCI Bridge (rev b1)
    00:0a.0 Ethernet controller: NVIDIA Corporation MCP79 Ethernet (rev b1)
    00:0b.0 SATA controller: NVIDIA Corporation MCP79 AHCI Controller (rev b1)
    00:10.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
    00:15.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
    00:16.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
    02:00.0 VGA compatible controller: NVIDIA Corporation C79 [GeForce 9400] (rev b1)
    03:00.0 Network controller: Broadcom Limited BCM4321 802.11a/b/g/n (rev 05)
    04:00.0 FireWire (IEEE 1394): LSI Corporation FW643 [TrueFire] PCIe 1394b Controller (rev 07)
    
  • Would it be possible to set nomodeset as a parameter to your configuration?
    Select e for edit.
    Go to the line that has the word linux in it.
    Within that line there might be the words quiet splash.
    Place the word nomodeset BEFORE those words.
    CTRL + X to reboot.
    If this solves the issue, do the following then:
    find your grub file and change the following:
    add nomodeset to GRUB_CMDLINE_LINUX_DEFAULT:
    then update your grub configuration.

    Please post your results if successful or not.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi @Modisc ,
    Thanks for the help, but in an act of despair I installed rEFInd (a boot manager for Mac’s) and it seems that it solved the issue… I will keep the thread open for a couple more days to make sure it’s permanent.

    Regards.

  • hi.
    I’m sorry that the issue wasn’t completely solved without having to install an external bootload mgr, but if rEFInd does the job or trick well enough, then I’m at least glad the problem is resolved. :)

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

black30 grub60 Posts 4Views 167
Log in to reply