• Auto-rotation in Gnome


    Hello! I am a new Antergos user and this distro has been wonderful. Well I can’t get auto-rotation to work with my Lenovo Yoga 300. Auto-rotate has worked with no distro so far (it has only worked with Windows) and I hope it might work with this.

    System:    Host: lenovoyoga Kernel: 4.10.9-1-ARCH x86_64 (64 bit)
               Desktop: Gnome 3.22.3 Distro: Antergos Linux
    Machine:   Device: laptop System: LENOVO product: 80M1 v: Lenovo Yoga 300-11IBR
               Mobo: LENOVO model: Mini v: SDK0J40679WIN
               UEFI: LENOVO v: C7CN27WW date: 10/28/2015
    Battery    BAT1: charge: 7.1 Wh 26.3% condition: 27.0/30.0 Wh (90%)
    CPU:       Quad core Intel Pentium N3700 (-MCP-) cache: 1024 KB 
               clock speeds: max: 2400 MHz 1: 483 MHz 2: 563 MHz 3: 649 MHz
               4: 793 MHz
    Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
               Display Server: N/A drivers: intel (unloaded: modesetting,fbdev,vesa)
               Resolution: 80x24
    Audio:     Card Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller
               driver: snd_hda_intel
               Sound: Advanced Linux Sound Architecture v: k4.10.9-1-ARCH
    Network:   Card-1: Intel Wireless 3160 driver: iwlwifi
               IF: wlp2s0 state: up mac: 2c:6e:85:0f:6b:03
               Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
               driver: r8169
               IF: enp3s0 state: down mac: 1c:83:41:12:02:f9
    Drives:    HDD Total Size: 500.1GB (3.2% used)
               ID-1: /dev/sda model: ST500LM000 size: 500.1GB
    Partition: ID-1: / size: 154G used: 12G (8%) fs: ext4 dev: /dev/sda2
               ID-2: swap-1 size: 4.20GB used: 0.00GB (0%) fs: swap dev: /dev/sda11
    Sensors:   None detected - is lm-sensors installed and configured?
    Info:      Processes: 172 Uptime: 40 min Memory: 1330.3/3867.4MB
               Init: systemd Client: Shell (bash) inxi: 2.3.8 
    
    
  • Forgot to mention that I also have iio-sensor-proxy installed as suggested by searching online.

  • https://wiki.archlinux.org/index.php/Tablet_PC#Touchscreen_rotation
    https://wiki.archlinux.org/index.php/Lenovo_IdeaPad_Yoga_900#Screen_Rotation
    Do you read here?
    You can easily rotate screen with xrandr, however it does not rotate touchscreen/touchpad input which makes it fairly awkward to use. There is a project attempting to address this. Keyboard hardware-disables in tablet mode, but touchpad is still active which needs to be addressed. No ACPI or keycode signals appear to be emitted for the various screen rotation states.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

auto-rotation1 gnome209 Posts 3Views 266
Log in to reply