Hi,

I’m new here, so please forgive/indulge my OCD :)

When I installed Antergos, I chose to use ZFS (because I’m a nerd, and running ZFS is awesome). For the most part, it runs great. But when I boot up, I always get a specific set of error messages relating to ZFS which I would appreciate being able to hide, or better yet, resolve, if possible.

These are the error messages:

ERROR: resume: no device specified for hibernation
ash: 1: unknown operand
cannot open 'antergos_0nu6': no such pool
no pools available to import

I have since tried setting ZFS’ swap partition for hibernation (not that I ever use it - I just hate error messages) but now the first line reads:

ERROR: resume: hibernation device 'zd0' not found

I also tried silencing the boot process by following these instructions on the Arch Wiki, and adding the following to the kernel line in /etc/default/grub:

quiet loglevel=0 rd.systemd.show_status=auto rd.udev.log-priority=0 vt.global_cursor_default=0

That silences everything except the four lines I actually want silenced.

I don’t have high hopes for being able to fix this extremely minor niggle, but if anyone can tell me how to either resolve the underlying issue, or at least hide these error messages I would be eternally grateful!