• Cannot update packages (Spotify and Wine) - Error Inside


    Hello Everyone,

    As the subject states, I keep getting the following error when trying to update WINE or Spotify:
    http://imgur.com/a/Wj0Mm

    Can anyone tell me how to get the correct dependencies installed so I can install these updates correctly please?

    Thank you in advance for everyone’s time and help, it is greatly appreciated!

  • You should install the dependencies
    sudo pacman -S openssl
    yaourt libcurl-openssl
    Then try again

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Not a really good answer.

    This is an update to the app, the dependencies should already be there. I had the same issue and decided to uninstall it instead to not deal with it.

    I believe the openssl was updated to a new version or something else replaced it in the system, and spotify is not aware of that, or something like that. So if you were to install that openSSL back, it could break something else.

  • So did you uninstall and then reinstall? Can you post your exact steps / commands you took please?

    Thanks,
    Asif

  • Sorry no.

    I never re-installed it. I was in a bad mood so I decided to not use it, just started using the web version.

    The above idea may work, I would just be worried it could break something else. I feel something else is going on here. Sorry I can’t be of more help.

  • sudo pacman -S openssl
    yaourt libcurl-openssl

    These 2 commands did not fix my issue. I am still getting a Spotify notification in the software update screen. Any help or assistance would be greatly appreciated!

    Thanks!

  • [email protected] ~  
    ╰─➤  yaourt libcurl-openssl
    1 aur/libcurl-openssl-1.0 7.53.1-1 (2) (1,70)
        An URL retrieval library (build against openssl-1.0)
    ... 
    
    

    openssl-1.0 is not in AUR nor Repo it is only in testing at the moment…

    https://www.archlinux.org/packages/?q=openssl-1.0

    READ THE SOURCE:
    Currently this package is only compatible with [testing].

    The purpose is to provide curl libs compiled against openssl-1.0 when the curl and openssl packages in [testing] are moved to the stable repos.
    Spotify will need this for example. The curl packages in [testing] are compiled against openssl 1.1 https://aur.archlinux.org/packages/libcurl-openssl-1.0/?comments=all

    You can try installing it locally:
    download: https://www.archlinux.org/packages/testing/x86_64/openssl-1.0/download/
    and install with pacman -U PACKAGE

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad @a4orce84 sorry, i recommended it because i didn’t find another libcurl-openssl than the AUR.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto no regret ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad
    OFFTOPIC: one thing i can say is that follwing your advice to update once a week save me from some problems, i’ll update next friday, so untill there probably a fix is done or at least a workaround. (WINE is here waiting to update)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto said in Cannot update packages (Spotify and Wine) - Error Inside:

    (WINE is here waiting to update)

    Also here

    Autodidacta en la VIDA …y en Linux, también.

  • Hey Guys,

    Thanks for the responses everyone. I am still a bit confused on how to prevent seeing the dependency issues and getting a spotify notification in software update. I want to clear this issue, so there are no updates basically.

    @joekamprad - I tried your suggestion here:
    http://imgur.com/a/GsZWm

    Looks like I am still getting an error. This is what I see in software update still:
    http://imgur.com/a/Wj0Mm

    Thanks again for everyone’s time and help with this issue, it is greatly appreciated.

  • @a4orce84 https://forum.antergos.com/topic/6617/spotify-1-0-53-758-1/2

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto - It appears that the post you linked is in another language. Is there something specific you are referring to?

    Thanks,
    Asif

  • @a4orce84 better to wait to new ssl is in repo…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • A few moments ago I just installed Spotify 1.0.53.758-1 without problems, without asking for any booksellers or anything !!!

    Autodidacta en la VIDA …y en Linux, también.

  • @a4orce84 said in Cannot update packages (Spotify and Wine) - Error Inside:

    @fernandomaroto - It appears that the post you linked is in another language. Is there something specific you are referring to?

    Thanks,
    Asif

    No i just posted @Velkerk post about the same problem and how he fixed, although he didn’t mention wine update/problem

    @judd said in Cannot update packages (Spotify and Wine) - Error Inside:

    A few moments ago I just installed Spotify 1.0.53.758-1 without problems, without asking for any booksellers or anything !!!

    Nice!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I am still seeing the issue:
    http://imgur.com/a/ibpOy

  • @joekamprad said in Cannot update packages (Spotify and Wine) - Error Inside:

    @a4orce84 better to wait to new ssl is in repo…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • BTW i do not know why https://www.archlinux.org/packages/community/x86_64/libcurl-compat/
    is a dependency of spotify and this is depending on openssl from repo so i have no clue why your pamac is saying libopenssl-1.0-compat and libcurl-openssl-1.0 is a dependency there are both not a direct or indirect dependency …

    Me too i can install spotify from AUR without any error or failing…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

wine14 error174 spotify9 inside2 Posts 20Views 966
Log in to reply