• Resolucion de pantalla baja, en el inicio Grub.


    Buenas tardes !

    Acabo de hacer una instalación Cnchi 0.14.257 (ya se versión muy vieja, pero funcionó muy bien…) en una computadora de escritorio con Gnome 3.22.2, con estas caracteristicas:

    $ lspci
    00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS880 Host Bridge
    00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
    00:05.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 1)
    00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5)
    00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
    00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
    00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
    00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3c)
    00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller
    00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
    00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
    00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
    00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
    00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
    00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
    00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
    00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670]
    01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series]
    02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
    04:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
    
    
    $ sudo lshw -class display
    [sudo] password for judd: 
      *-display                 
           description: VGA compatible controller
           product: Turks XT [Radeon HD 6670/7670]
           vendor: Advanced Micro Devices, Inc. [AMD/ATI]
           physical id: 0
           bus info: [email protected]:01:00.0
           version: 00
           width: 64 bits
           clock: 33MHz
           capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
           configuration: driver=radeon latency=0
           resources: irq:31 memory:d0000000-dfffffff memory:fdec0000-fdedffff ioport:ee00(size=256) memory:c0000-dffff
    
    
    $ screenfetch -p
                   `.-/::/-``                
                .-/osssssssso/.              
               :osyysssssssyyys+-            
            `.+yyyysssssssssyyyyy+.          
           `/syyyyyssssssssssyyyyys-`        
          `/yhyyyyysss++ssosyyyyhhy/`        
         .ohhhyyyyso++/+oso+syy+shhhho.      
        .shhhhysoo++//+sss+++yyy+shhhhs.     
       -yhhhhs+++++++ossso+++yyys+ohhddy:    
      -yddhhyo+++++osyyss++++yyyyooyhdddy-   
     .yddddhso++osyyyyys+++++yyhhsoshddddy`  
    `odddddhyosyhyyyyyy++++++yhhhyosddddddo  
    .dmdddddhhhhhhhyyyo+++++shhhhhohddddmmh. 
    ddmmdddddhhhhhhhso++++++yhhhhhhdddddmmdy 
    dmmmdddddddhhhyso++++++shhhhhddddddmmmmh 
    -dmmmdddddddhhyso++++oshhhhdddddddmmmmd- 
     .smmmmddddddddhhhhhhhhhdddddddddmmmms.  
       `+ydmmmdddddddddddddddddddmmmmdy/.    
          `.:+ooyyddddddddddddyyso+:.`       
    
     [email protected]
     OS: Antergos 
     Kernel: x86_64 Linux 4.10.9-1-ARCH
     Uptime: 7m
     Packages: 1043
     Shell: bash
     Resolution: 1440x900
     DE: GNOME 
     WM: GNOME Shell
     WM Theme: Numix-Frost
     GTK Theme: Numix-Frost-Light [GTK2/3]
     Icon Theme: Numix-Square
     Font: Cantarell 11
     CPU: AMD Phenom II X2 560 @ 2x 3.3GHz [35.5°C]
     GPU: Gallium 0.4 on AMD TURKS (DRM 2.49.0 / 4.10.9-1-ARCH, LLVM 3.9.1)
     RAM: 806MiB / 3952MiB
    
    

    He desactivado el inicio con Lightdm y arranco con Gdm, he aqui el problema cuando bootea el sistema, en la pantalla de Grub, se ven las letras muy grandes y se van de cuadro, y la resolucion de pantalla muy ampliada, aunque luego de loguearme todo se inicia en correcto orden.

    $ journalctl -b -2
    

    https://privatebin.net/?c3a22fc09171d4aa#ofvHtbuaZU5JccmDKSvTrgacEnvvBIxzkMxp02Ofcws=

    /var/log/cnchi
    

    http://pasted.co/ce376483

    Me falta en el panel superior derecho el control de brillo…

    Gracias como siempre !!!

    Autodidacta en la VIDA …y en Linux, también.

  • Hola,

    Si vas a la consola con CTRL+ALT+F2 se ve todo grande también?

    Entonces quizás esto te ayude:
    http://pierre.baudu.in/other/grub.vga.modes.html

    Debes modificar el /etc/default/grub, la línea que empieza por GRUB_CMDLINE_LINUX_DEFAULT y añadir dentro de las comillas la opción vga=valor
    (siendo valor la resolución que quieras según el enlace que te he pasado).

    Recuerda luego generar otra vez el menú de grub con:
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Si no, el problema es meramente estético, no me preocuparia mucho.

    Saludos!

  • @karasu said in Resolucion de pantalla alta, en el inicio.:

    Debes modificar el /etc/default/grub, la línea que empieza por GRUB_CMDLINE_LINUX_DEFAULT y añadir dentro de las comillas la opción vga=valor
    (siendo valor la resolución que quieras según el enlace que te he pasado).

    Hola @karasu !

    Dentro de esa línea que tu me indicas, tengo esto:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=f436f918-e6f7-4fe5-a79d-1c71e1f0d566"
    

    Y sobre agregarle el valor, de la pagina que tu mencionas, mi resolución no se encuentra, cual es de 1440x900 o bien sería 834…?

    Edito= probé con 834 y me tira pantallazo “frecuencia no soportada”

    Ahora bien; como hago para saber la “profundidad de color” o “Colour depth” ???

    Autodidacta en la VIDA …y en Linux, también.

  • @karasu said in Resolucion de pantalla alta, en el inicio.:

    Si vas a la consola con CTRL+ALT+F2 se ve todo grande también?

    No se ve muy chiquitas las letras, ahi que acercarse demasiado a la pantalla para ver bien que dice y no tiene una buena definición tampoco.

    Otro=

    Me falta en el panel superior derecho el control de brillo… ??? No se por que pueda ser que NO se haya instalado…

    Autodidacta en la VIDA …y en Linux, también.

  • @judd said in Resolucion de pantalla alta, en el inicio.:

    Ahora bien; como hago para saber la “profundidad de color” o “Colour depth”

    $ cat /var/log/Xorg.0.log | grep Depth
    [    20.668] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
    [    23.743] (--) Depth 24 pixmap format is 32 bpp
    
    

    Cual tendría que usar 24 o 32 ???

    Autodidacta en la VIDA …y en Linux, también.

  • Hola!

    Lo siento, estaba en la playa sin ordenador xD

    Lo has podido solucionar? Usa una porfundiad de 24 si puedes (depende de lo vieja que sea la tarjeta gráfica y el monitor).

    Por ejemplo:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=f436f918-e6f7-4fe5-a79d-1c71e1f0d566 vga=792"

    Lo del panel del brillo ni idea… pero parece que esos iconos aparecen y desaparecen según la versión del kernel… ¿?

    Cuando dices “en la pantalla de grub” te refieres a cuando sale el menú y también posteriormente cuand carga systemd y demás?

    Saludos!

  • @karasu said in Resolucion de pantalla alta, en el inicio.:

    Lo has podido solucionar? Usa una porfundiad de 24 si puedes (depende de lo vieja que sea la tarjeta gráfica y el monitor).
    Por ejemplo:
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=f436f918-e6f7-4fe5-a79d-1c71e1f0d566 vga=792”

    Hola @karasu !

    Imposible de solucionar, ya probre todas las resoluciones posibles y todas vuelven a 1440x900. No ahi problema con esto, es meramente estetico en el arranque, además ya sabemos que Amd/Radeon son un dolor de cabeza…

    Lo del panel del brillo ni idea… pero parece que esos iconos aparecen y desaparecen según la versión del kernel… ¿?

    Pues yo tampoco y en los foros como en San Google no ahi mucho y no me sirve: 0_1492443198348_brillo.png

    Cuando dices “en la pantalla de grub” te refieres a cuando sale el menú y también posteriormente cuand carga systemd y demás?

    Exactamente, pantalla logo antergos y los kernel

    Lo siento, estaba en la playa sin ordenador xD
    **Exelente opción :sunglasses: ;)

    Autodidacta en la VIDA …y en Linux, también.

  • Puedes probar a cargar el módulo radeon en el fichero mkinitcpio.conf

    sudo nano /etc/mkinitcpio.conf

    y donde pone MODULES="" cámbialo por MODULES="radeon"

    Luego debes volver a generar el initcpio:
    sudo mkinitcpio -p linux

    Te saldrán varios warnings… ni caso.

    Reinicias… cargará el módulo Radeon mucho antes en el inicio, quizás ayude, quizás no.

    Saludos!

  • @karasu said in Resolucion de pantalla alta, en el inicio.:

    Quizás AYUDE, quizas no.

    No funcionó, igualmente gracias como siempre y dejo el tema como resuelto !

    Salu2.-

    Autodidacta en la VIDA …y en Linux, también.

  • sudo nano /etc/default/grub
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE="1440x900"
    
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad said in Resolucion de pantalla alta, en el inicio.:

    sudo nano /etc/default/grub
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE="1440x900"
    
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Hi @joekamprad !

    I just performed the operation, it did not work, I also agradesco your attention !!!

    Autodidacta en la VIDA …y en Linux, también.

  • @judd

    Cuando arranca el ordenador y te aparece el grub, presiona la tecla c para abrir la consola de grub.

    Tecleea vbeinfo y te mostrará los modos de pantalla que puedes seleccionar con el método de @joekamprad

    Saludos!

  • @karasu said in Resolucion de pantalla alta, en el inicio.:

    @judd

    Cuando arranca el ordenador y te aparece el grub, presiona la tecla c para abrir la consola de grub.

    Tecleea vbeinfo y te mostrará los modos de pantalla que puedes seleccionar con el método de @joekamprad

    Saludos!

    Lo realize de esta manera
    0_1492609915005_20170419_103003.jpg
    tal ves mal
    0_1492609973122_20170419_104110.jpg
    aunque así, a mi forma, no dió resultado
    0_1492610015892_20170419_104405.jpg

    Autodidacta en la VIDA …y en Linux, también.

  • El lugar equivocado! Hay que cambiar la línea en el /etc/default/grub, y reconstruir el grub.cfg como he descrito anteriormente:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    El comando vbeinfo sólo muestra todas las resoluciones posibles. La resolución es de 1440x900, por lo que yo puedo ver, no se ofrece. Tiene una de las resoluciones se votan para mostrarse con vbeinfo.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad said in Resolucion de pantalla alta, en el inicio.:

    El lugar equivocado! Hay que cambiar la línea en el /etc/default/grub, y reconstruir el grub.cfg como he descrito anteriormente:
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    A ver si entiendo bien, ahi que cambiar la resolución de 1440x900 por las opciones que tira vbeinfo ???

    El comando vbeinfo sólo muestra todas las resoluciones posibles. La resolución es de 1440x900, por lo que yo puedo ver, no se ofrece. Tiene una de las resoluciones se votan para mostrarse con vbeinfo.

    Entonces seria algo como:

    GRUB_GFXMODE="nueva resolución" ¿?
    

    Autodidacta en la VIDA …y en Linux, también.

  • ENGLISH
    

    @joekamprad said in High Screen Resolution, at the beginning:

    The wrong place! You have to change the line in / etc / default / grub, and rebuild grub.cfg as described above:
    Sudo grub-mkconfig -o /boot/grub/grub.cfg

    To see if I understand well, there to change the resolution of 1440x900 by the options that strip vbeinfo ???

    The vbeinfo command only shows all possible resolutions. The resolution is 1440x900, so I can see, it is not offered. Has one of the resolutions are voted to be displayed with vbeinfo.

    Then it would be something like:

    GRUB_GFXMODE = “new resolution”?

    Autodidacta en la VIDA …y en Linux, también.

  • He probado varias resoluciones y profundidad:

    GRUB_gfxmode="1400x1050x32"
    

    0_1492621787326_cfg.png
    Como resultado:
    0_1492621930992_20170419_140057.jpg
    Frecuencias no soportadas
    como tampoco puedo ver bien encuadrado dentro de una TTy:
    0_1492622641746_20170419_135949.jpg

    Con 1400x1050x24
    0_1492622085801_20170419_104405.jpg
    igual que antes

    Con 1400x1050x28
    0_1492622143116_20170419_104405.jpg
    igual que antes

    Con 1400x1050x30
    Lo mismo, igual que antes

    Conclusión=
    Me quedo con la primera prueba de resolución=1400x1050x32, cual es la más pequeña que encontré con vbeinfo

    Sepan disculpar la desprolijidad.
    Gracias

    Autodidacta en la VIDA …y en Linux, también.

bios15 kvm2 disable11 Posts 17Views 844
Log in to reply