• Like 0

    FFMPEG


    So this is probably a stupid question, but how does one go about using FFMPEG to clip video? I thought I was doing it correctly, but it is never able to find my file. I’ve searched Google and read the documentation, but have only found results for Windows users. As I am not a Windows user, I thought I would ask here to see if anyone knew.

    Thank you!

  • Like 0

    @moredoor Is done through command line like:

    Remove audio:
    ffmpeg -i video.mp4 -an mute-video.mp4

    convert from one format to another:
    ffmpeg -i original.MOV final.rmvb

    So it all depends of what you need, then check the ffmpeg manual

    man ffmpeg or ffmpeg --help

    I recommend to run the command directly in you video folder, so the final video will be created there.

    Cheers!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    @fernandomaroto Thank you so much, but it is still saying ‘no such file or directory’.

  • Like 0

    @moredoor are you opening the terminal in the right folder? (or using cd command to the right place)
    Another possible thing is that you’re using the wrong order like:
    ffmpeg [options] [new_file] [original_file]

    instead of the right way:
    ffmpeg [options] [original_file] [new_file]

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    @fernandomaroto I am opening it directly from my Videos folder, where my video is.

    ffmpeg -i plc.mp4 -ss [06:35:00] -t [01:00:00] -c pl1.mp4
    

    That is the command I am using.

  • Like 0

    from this forum https://superuser.com/questions/138331/using-ffmpeg-to-cut-up-video there is an extra .0 and the command is a little bit different
    ffmpeg -i input.wmv -ss 00:00:30.0 -c copy -t 00:00:10.0 output.wmv

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    @fernandomaroto Still unable to find the file. Thank you for that correction though!

  • Like 0

    @moredoor well, then you’ll have to dig further on internet, can’t help you further.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    IF ffmpeg is not finding your file then supply the full pathname of the file. If you want to avoid having to provide the full pathname, first make sure your current working directory is the one where the video is. Use the cd command (“change directory”) to change to the directory containing the file. Then you can execute the command without having to tell ffmpeg where it is, because ffmpeg will look in the current directory.

ffmpeg1 Posts 9Views 153
Log in to reply