• Fonts other than English show up as square blocks


    Issue found only within web browsers. Tried Chromium, Firefox and Opera. All showing the same issue. Tried changing the fonts mentioned within browser but that changes nothing.
    I am using Gnome and also tried some extensions for Chromium to check the issue. No change.
    While installing I didnt select the Extra true type fonts package. Can anybody guide me if this will fix the issue.

    0_1492008237970_Screenshot from 2017-04-12 20-13-19.png

  • @surfermj Hey,

    I had the same issue but quickly realised that I needed to install addition fonts. I see that you were trying to use Google India, so you probably need a Hindi font.

    A quick search on the net, made my find this webpage with good fonts:
    http://indiatyping.com/index.php/download/hindi-fonts

    Read through that page to know more about these fonts. If I were you, I’d install both the legacy and unicode ones, both regular and bold at least. Download and open the archives, open the font file and click on install in that window. Restart your browser after installing all the fonts.

    For other fonts (CN, JP, KR, …), search in the community repo for the Adobe fonts. They are wonderful, but unfortunately I couldn’t find a Hindi one.

    Just a tip: the default fonts don’t only support English, but most of the western languages, even Greek and Russian, as far as I know.

    Hope this helped

    -= PC =-
    Antergos & Windows 7 Pro | Asrock x370 K4 - Ryzen 1600 - GTX 950 (replace with Radeon 570/580/Vega) - 16GB DDR4 2400 - Samsung 960 pro 512GB (Windows) + Samsung 850 EVO 256 GB (Antergos) + 2x 2TB HGST HDD RAID1 + 1TB Seagate HDD - RM550x Gold PSU

  • Thanks EarthMind
    I read that the issue might be due to font rendering. Since I can read the Hindi, Malayalam fonts in websites. I checked out the news websites like http://www.bhaskar.com/, http://www.manoramaonline.com/ etc and can read the fonts. But not the ones like in Google, Facebook etc. They show up as squares.

  • I solved this installing the noto fonts, but installing only “opendesktop-fonts” may also do.

  • @antimony Have installed the fonts now.
    Does this get enabled automatically or is there anything to do once installed?

  • You should perhaps update the font cache:

    fc-cache -fv

    (run this command as ordinary user)

  • Did that…no change unfortunately. Should I try Noto fonts. If so, pls tell how. Thanks

  • For me, it worked installing the three noto font packages in the software center.

  • @antimony Thanks a lot. Noto fonts installation seems to have fixed this issue.
    Installed the ones I needed from this link https://www.google.com/get/noto/
    Then ran fc-cache -fv
    Voila!
    Now I can see the desired fonts in webpages instead of square blocks. (some showing square are the ones which I dont require)

    0_1492506119080_Screenshot from 2017-04-18 14-28-29.png

fonts8 english2 show11 square1 Posts 9Views 308
Log in to reply