• Failed to Load Kernel Modules


    I’m back on Antergos after a few experiments on other distros and I’ve noticed something during boot that I’d like to see if I can address. I am running the GNOME desktop with the LTS kernel. When booting I get the message “Failed to load kernel modules.” Entering “sudo systemctl status systemd-modules-load.service” returns

    [code][[email protected] ~]$ sudo systemctl status systemd-modules-load.service
    [sudo] password for chas: 
    ● systemd-modules-load.service - Load Kernel Modules
       Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static;
       Active: failed (Result: exit-code) since Tue 2017-04-11 19:39:24 EDT; 9min ag
         Docs: man:systemd-modules-load.service(8)
               man:modules-load.d(5)
      Process: 155 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, sta
     Main PID: 155 (code=exited, status=1/FAILURE)
    
    Warning: Journal has been rotated since unit was started. Log output is incomple
    lines 1-9/9 (END)...skipping...
    ● systemd-modules-load.service - Load Kernel Modules
       Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
       Active: failed (Result: exit-code) since Tue 2017-04-11 19:39:24 EDT; 9min ago
         Docs: man:systemd-modules-load.service(8)
               man:modules-load.d(5)
      Process: 155 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
     Main PID: 155 (code=exited, status=1/FAILURE)
    
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    lines 1-9/9 (END)
    

    Running “sudo /usr/lib/systemd/systemd-modules-load” returns

    Failed to find module 'acpi_call-lts'
    

    Does anyone know what the issue is here and how to fix it?

    Thanks!

  • I checked the links and the Arch Wiki and that led me to creating a file in /etc/modules-load.d called “acpi_call-lts.conf” with the text

    # Load acpi_call-lts at boot
    acpi_call-lts
    

    However that does not seem to have had any effect

  • @chasbel2112 Try sudo pacman -install acpi_call_lts

    'Could be worse. 'Could be raining.
    Mike Bee

  • Mike- that returned the following:

    pacman: invalid option -- 'a'
    
  • Sorry. I usually use the gui tool to add software. It’s sudo pacman -S acpi_call_lts

    'Could be worse. 'Could be raining.
    Mike Bee

  • No problem, but you should know that the name of the package is acpi_call-lts, no second underscore.
    Also it’s already installed on my machine.

  • Have you gone through this? https://wiki.archlinux.org/index.php/kernel_modules

    'Could be worse. 'Could be raining.
    Mike Bee

  • Yes. You’ll notice in post #3 I indicated that I had taken such steps

  • I’m sorry that I’m not being very helpful. I’m new to Arch too. The only other advice I can give you is to check the spelling of everywhere the name is used. I had a problem for example where the system had a symbolic link with the wrong spelling. So my realtk card’s driver wasn’t loading. Also there may be an acpi bios setting on your machine that needs to be checked. Good luck. If I think of anything else I’ll let you know.

    'Could be worse. 'Could be raining.
    Mike Bee

modules4 kernel58 Posts 10Views 200
Log in to reply