• Monitor doesn't suspend


    Hi

    I’m new to Antergos and the Arch scene and I’m loving the experience so far. I have an issue with my LG monitor though. For the first time, I experience that it doesn’t suspend in Linux after the set inactivity time. It’s set to go black after 15 minutes, but I noticed that it always stays on.

    Anyone have any idea to solve this? The Arch wiki didn’t help me out on this one.

    Thanks

  • $ journalctl --since "15 minutes ago"
    

    Autodidacta en la VIDA …y en Linux, también.

  • Hi judd

    It gives me the message
    -- No entries --

    Isn’t the setting Black Screen in the Energy section of the control panel suffcient to modify? I’ve set that to 15 minutes. See:

    alt text

  • @EarthMind said in Monitor doesn't suspend:

    Isn’t the setting Black Screen in the Energy section of the control panel suffcient to modify? I’ve set that to 15 minutes. See:

    Of course, graphically it has to work like that.

    Try rebooting, see what happens …

    Autodidacta en la VIDA …y en Linux, también.

  • nope:
    the internal Gnome settings do only work together with GDM, not with lightdm.
    But as far as i know there are the issue that the light-locker > light-locker-settings does not save the settings for a long time.
    But you can try may it is fixed ???
    Try to setup your offtime inside light-locker-settings GUI

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @EarthMind And to make shure you can use also GDM if you like, but theming is not so easy…
    You can install gdm3setup and change the background with this trick: change gdm background

    sudo pacman -S gdm 
    sudo systemctl -f disable lightdm
    sudo systemctl -f enable gdm
    sudo reboot
    

    After this you will be welcomed with gdm DM and you can use gnome-settings to change monitor off times e-t-c-

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • This post is deleted!
  • @joekamprad Thanks for the solution! I tried it out by modifying the settings in light-locker-settings and it worked. I’ll keep an eye on it whether it loses its settings. If so, I’ll try your second advice and report back.

    Update:
    @joekamprad said in Monitor doesn't suspend:

    light-locker-settings

    light-locker-settings isn’t a reliable solution unfortunately. It works for some time but later on the settings aren’t respected anymore.

  • Unfortunately GDM isn’t a good solution either, because everything goes a lot slower when using it. The opening of windows take much longer, the internal drives that show up, show up in the file manager all messed up…

  • What are your specs then?
    should not be like this on a common machine…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad FX-6100 12GB RAM Nvidia GTX 950 Samsung SSD

    It’s strange yes, but it started taking a lot longer opening windows.

  • can you give us:

    journalctl -b -0 > journal.txt
    

    pastebin it and post the link here

    https://bpaste.net/show/073ed6622fd2

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • That won’t be necessary, I’m glad. I tried it again and now GDM seems to be functioning just right. The energy settings are also working properly.

    One thing that’s not working right all the time are the shutdown & restart buttons in the top right menu. After some time, don’t really know when and why exactly, they disappear and I can only restart and shutdown with CTRL + ALT + DEL.

suspend26 monitor21 Posts 13Views 543
Log in to reply