• Recently multitouch detection on track pad sucks.


    In the last week or two the multitouch detection on my track pad has sucked. Ever since I first installed Antergos it has worked wonderfully but now it’s spotty at best and I’m not sure why or how to fix it.

    Laptop - lenovo y-50
    using libinput with nothing else on top
    the only gestures I really need is two finger scrolling, two finger right click, three finger middle click, and pinch zooming.

    is there something I should install on top of libinput for help with this?

    To clarify by spotty meaning they do work, but I’ve got a bout a 70% chance of it not recognizing that I’m using more than one finger.

  • what says:

    demsg | grep elantech
    

    ???

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • this is my dmesg | grep elantech

    [ 19.436428] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x495f01)
    [ 19.446612] psmouse serio1: elantech: Synaptics capabilities query result 0x70, 0x15, 0x0e.
    [ 19.456945] psmouse serio1: elantech: Elan sample query result 02, 33, 75

  • The holy ArchWiki says:
    If a touchpad device is not detected and shown as a device at all, a possible solution might be using one or more of these kernel parameters:
    i8042.noloop i8042.nomux i8042.nopnp i8042.reset

    sudo nano /etc/default/grub
    

    change the line :

    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    

    to:

    GRUB_CMDLINE_LINUX_DEFAULT="i8042.notimeout i8042.nomux quiet"
    
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    sudo grub-install /dev/sdX
    

    X change to your value

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad This seems to have worked. Thanks a ton for your help it was driving me crazy.

  • good to know! mark as soveld when verified 😉

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

laptop41 lenovo15 trackpad7 multitouch2 Posts 6Views 881
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.