• Upgraded to 4.10.8 kernel(?), machine wont boot.


    I upgraded what I’m assuming is the kernel yesterday. The upgrade file was something like linux 4.18.8. Now on boot I get the following error:

    Warning /lib/modules/4.10.8-1-ARCH/modules.devname not found

    Waiting 10 seconds for device /dev/disk/by-uuid/ff07ede6-de6a-4f95-bd30-87d157251b9

    Error device ‘UUID ff07ede6-de6a-4f95-bd30-87d157251b9’ not found

    I’m on a mac mini, booting up using rEFInd, no grub installed.

    Thanks.

  • i do not know about your bootmanagers behavior but looks like kernel update was not finnished?
    You can boot with LiveIso chroot and reinstall kernel package.

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • @joekamprad said in Upgraded to 4.10.8 kernel(?), machine wont boot.:

    You can boot with LiveIso chroot and reinstall kernel package.

    I’m in LiveIso now and trying to figure out how to reinstall the kernel. Do you have a link that might help in figuring it out?

  • mount root [ / ] to /mnt
    mount /boot to /mnt/boot

    sdXn may be different to your setup …

    sudo mount /dev/sdXn  /mnt
    
    sudo mount /dev/sdXn /mnt/boot
    
    sudo arch-chroot /mnt
    
    sudo pacman -Sy linux
    

    https://wiki.archlinux.org/index.php/Change_root

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • Thanks, that helped a lot. I was able to downgrade the kernel and I’m back in.

boot256 kernel119 upgraded4 4.10.81 Posts 5Views 905
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.