• Bluetooth Settings & Network Manager Issues


    I have two new issues. Starting to get pissed as these small-ish issues keep happening which seems for no reason.

    Either clicking on the icon within the menu or within the Settings area, Bluetooth (for bluetooth settings) does nothing. The mouse shows the animation but nothing ever happens.

    Second issue is the stupid Network Manager icon in the system tray. I had an applet installed for it, removed it, but it was replaced with a different one. One that is part of the system tray icons (so if I remove it, it removes my other apps). How do I get rid of just that icon.

    I am using the Cinnamon DE.

  • For bluetooth check if your device is working properly:

    bluetoothctl
    

    In a Terminal should give you something like this:

    bluetoothctl
    [NEW] Controller 00:19:83:5D:F6:E9 hostnameXY [default]
    

    Also:

    systemctl status bluetooth
    

    will show if bluetooth is loaded properly

    There are sometimes problem with wifi><bluetooth combinated chipsets, and some bt-devices need a firmware to work fully…

    sudo pacman -S bluez-firmware
    

    will solve missing firmware…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Well as I said, the device I have is working no problem, it’s simply the menu.

    [NEW] Controller 5C:F3:70:6B:81:3B mumu [default]
    [NEW] Device 00:18:00:3B:8B:53 Majestouch Convertible 2```
    
    
    
    ```● bluetooth.service - Bluetooth service
      Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor pr
      Active: active (running) since Sat 2017-04-01 23:56:45 EDT; 8h ago
        Docs: man:bluetoothd(8)
    Main PID: 379 (bluetoothd)
      Status: "Running"
       Tasks: 1 (limit: 4915)
      CGroup: /system.slice/bluetooth.service
              └─379 /usr/lib/bluetooth/bluetoothd
    
    Apr 01 23:56:45 mumu systemd[1]: Starting Bluetooth service...
    Apr 01 23:56:45 mumu bluetoothd[379]: Bluetooth daemon 5.44
    Apr 01 23:56:45 mumu systemd[1]: Started Bluetooth service.
    Apr 01 23:56:45 mumu bluetoothd[379]: Starting SDP server
    Apr 01 23:56:46 mumu bluetoothd[379]: Bluetooth management interface 1.14 initia
    Apr 01 23:56:54 mumu bluetoothd[379]: Endpoint registered: sender=:1.48 path=/Me
    Apr 01 23:56:54 mumu bluetoothd[379]: Endpoint registered: sender=:1.48 path=/Me
    lines 1-17/17 (END)```
    
    So should I still run that last command? Since things are working (except the settings options)
  • Guess what!

    As I was testing this further an update for bluberry came out. It fixed everything :)

  • Good that updates also fixing stuff ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

bluetooth22 issues34 manager36 Posts 5Views 268
Log in to reply