• Help with grub2


    I’ve never actually posted on a support forum before, but I am completely stumped. I’ve been working on this for a couple days now.
    I’ve been working on trying to install antergos linux on my laptop with a dual boot setup, the other os being Windows 8.
    Windows 8 in all cases will boot through the boot menu using f12. However, after using boot-repair on one of the linux distros, after I erased the partition and reformatted it to install antergos, now I have an error stating that the boot/grub/x86_64-efi/normal.mod file cannot be found. I tried boot-repair again and it told me to activate a repository that has grub-efi-amd64-signed packages in the software sourcesof antergos linux release 17.3(sda9)
    I’m decent with computers, but all my knowledge in programming, etc., doesn’t include much by way of linux, so I’m a true novice here, and no little to nothing about things like grub and repositories. Please help!

  • I want to add that I am still able to get into the installation of antergos using a flash drive containing supergrub2, so I can add the repository if I know which one is needed if that will make a difference, but I cannot find what to add when I google the error. Everything assumes I cannot get into the installation and wishes me to use chroot, which I’m not familiar with.

  • As UEFI hardware is very new and not much experience are collected, you need to have some passion to get stuff fixed ;)
    https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface

    /Me i do not own such hardware for now…
    And it seems like there is not the one way to make this working every provider have there own way to handle EFI/UEFI …

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @shenwolf82 So if I am understand your goal here, you are trying to dual boot with Windows 8. The laptop uses UEFI, and you’re getting grub errors after installing Antergos.

    Using my Surface Pro 3 as an example, I am dual booting with Windows 10 (10 is on the main SSD and Antergos is on a little sdcard). When you go to partition the drives and choose where grub goes, I believe you should choose the boot drive which your EFI partition is located on like SDA, not a partition like SDA1. Then, you need to choose the EFI partition, in my case it was like SDA3 or something, and make sure it is mounted as /efi. Then choose your other partitions and such like root, and boot if you want, etc, and away you go. I believe Antergos doesn’t do a proper os-prober run through for grub from cnchi since I didnt have an entry for windows 10 in my list initially, so you might need to do it after the fact but I know this process is a good start working with EFI partitions, so hopefully this helps since sometimes laptop partitioning and stuff can be a bit different if the manufacturer decided to do something weird.

    It’s important to note that when you mount the EFI partition DO NOT format it.

    Reference this post, I saw that another user on the Antergos forums used it and it worked for them. The installation guide is for Manjaro but the ideas are the same for cnchi. Notice, the last step is to update grub manually with update-grub to get your windows linked up in grub.

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

grub224 Posts 4Views 292
Log in to reply