• Screen flickers at lock screen and after unlock


    Hi,

    after the recent update to GNOME 3.12 I switched the graphics driver from Catalyst to the opensource one. Otherwise I was stuck in the boot process.

    Yesterday I noticed that the screen starts to flicker after waking up to the lock screen. After actually unlocking, the screen keeps flickering, but less and less. Right now the flicker resides at the top of the screen and is barely noticeable. [b:2old0bd4]Edit:[/b:2old0bd4] a few minutes ago it swítched to the left side, maybe a centimetre wide, then vanished.

    Is this maybe a coincidence that my screen is about to die after the driver change? Any ideas?

    Got a Radeon Sumo on-board graphics chip on a 64 bit system

    I’m currently searching the web and wiki for answers.

  • Hi,

    after the recent update to GNOME 3.12 I switched the graphics driver from Catalyst to the opensource one. Otherwise I was stuck in the boot process.

    Yesterday I noticed that the screen starts to flicker after waking up to the lock screen. After actually unlocking, the screen keeps flickering, but less and less. Right now the flicker resides at the top of the screen and is barely noticeable. [b:2old0bd4]Edit:[/b:2old0bd4] a few minutes ago it swítched to the left side, maybe a centimetre wide, then vanished.

    Is this maybe a coincidence that my screen is about to die after the driver change? Any ideas?

    Got a Radeon Sumo on-board graphics chip on a 64 bit system

    I’m currently searching the web and wiki for answers.

  • Hi,

    I could not find any similar reports so it doesnt look like this will be an easy one to solve. Wait a few days to see if it is corrected by any updates. If it continues to be a problem let me know and I will ask about it upstream.

    Cheers!

  • Seems to have resolved itself. No flickering at all anymore. Will get back to you if the problem reappears. Thanks!

  • @“dragonmagick”:2n238smz said:

    Seems to have resolved itself. No flickering at all anymore. Will get back to you if the problem reappears. Thanks![/quote:2n238smz]
    Awesome! Don’t forget to mark the thread solved if you feel your issue has been resolved.

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • It’s back. Actually, it came back a day after my posts here, didn’t have the time to post again. The whole login screen flickers around the borders and edges, looks a bit like a radial gradient from the center of the screen. The center flickers a little less than the outside. I’ll try and see if I can make a screenshot or a short video of it.

    In the meantime, the whole display started flickering though after a while it is only noticeable when you stare at the edges of the monitor, but it’s there. This whole affair looks like back with the old CRT when the refresh rate was at a low Hz value. Can this be a freak coincidence after I switched to the opensource driver?

    My xrandr output is as follows if that helps:

    [[email protected] ~]$ xrandr  
    Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192  
    VGA-0 disconnected (normal left inverted right x axis y axis)  
    LVDS connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 214mm  
    1600x900 60.12\*+  
    1440x900 59.89   
    1280x854 59.89   
    1280x800 59.81   
    1280x720 59.86   
    1152x768 59.78   
    1024x768 59.92   
    800x600 59.86   
    848x480 59.66   
    720x480 59.71   
    640x480 59.38
    
Posts 6Views 1878
Log in to reply