Hi,

I was running win10 and antergos as dual boot for some time now. However I accidentally reset the boot priority order in my UEFI to default again. After that the antergos-grub entry there was missing.

What I checked so far with antergos-minimal live linux:

$ fdisk -l
Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 00FDEA7B-985A-4570-AD8F-345F5A6F6761
Device         Start       End   Sectors   Size Type
/dev/sda1       2048    923647    921600   450M Windows recovery environment
/dev/sda2     923648   1128447    204800   100M EFI System
/dev/sda3    1128448   1161215     32768    16M Microsoft reserved
/dev/sda4    1161216 202665983 201504768  96.1G Microsoft basic data
/dev/sda5  213151744 243151743  30000000  14.3G Linux filesystem
/dev/sda6  243151744 259151743  16000000   7.6G Linux filesystem
/dev/sda7  259151744 500118158 240966415 114.9G Linux filesystem
/dev/sda8  202665984 213151743  10485760     5G Microsoft basic data
Partition table entries are not in disk order.

Disk /dev/sdb: 3.8 GiB, 4027580416 bytes, 7866368 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000
Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1  *     2048 7866367 7864320  3.8G  c W95 FAT32 (LBA)
Disk /dev/loop0: 533.5 MiB, 559435776 bytes, 1092648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
$ mount /dev/sda2 /mnt/
$ ls -R -la /mnt/
/mnt/: total 2
drwxr-xr-x 3 root root 1024 Jan  1  1970 .
drwxr-xr-x 1 root root  160 Mar 28 04:35 ..
drwxr-xr-x 5 root root 1024 Aug 22  2016 EFI

/mnt/EFI: total 5
drwxr-xr-x 5 root root 1024 Aug 22  2016 .
drwxr-xr-x 3 root root 1024 Jan  1  1970 ..
drwxr-xr-x 2 root root 1024 Aug 22  2016 antergos_grub
drwxr-xr-x 2 root root 1024 Aug  9  2016 Boot
drwxr-xr-x 4 root root 1024 Aug  9  2016 Microsoft

/mnt/EFI/antergos_grub: total 119
drwxr-xr-x 2 root root   1024 Aug 22  2016 .
drwxr-xr-x 5 root root   1024 Aug 22  2016 ..
-rwxr-xr-x 1 root root 119808 Aug 22  2016 grubx64.efi

/mnt/EFI/Boot: total 1168
drwxr-xr-x 2 root root    1024 Aug  9  2016 .
drwxr-xr-x 5 root root    1024 Aug 22  2016 ..
-rwxr-xr-x 1 root root 1193824 Mar  4 20:20 bootx64.efi

/mnt/EFI/Microsoft: total 8
drwxr-xr-x  4 root root 1024 Aug  9  2016 .
drwxr-xr-x  5 root root 1024 Aug 22  2016 ..
drwxr-xr-x 42 root root 5120 Aug  9  2016 Boot
drwxr-xr-x  2 root root 1024 Aug  9  2016 Recovery

/mnt/EFI/Microsoft/Boot: total 4575
# ...
# only microsoft stuff in some more directories

It seems that everything is still there, just not the entry in the UEFI boot options. So I cant start antergos atm.

Secure boot is off
Fast boot is off
UEFI boot only is on
CSM/Legacy is off

Always had win10-bootloader as default and could enter antergos when pressing f12 to get to the temporary startup device window, where the antergos-grub entry was. This entry is missing there now and in the UEFI boot priority order settings too. Windows is still booting normally.

Would be glad if somebody has advice on what I can do now

Edit:
In win10 i did:

bcdedit /set {bootmgr} path \EFI\antergos_grub\grubx64.efi

The bootmenu entry of the windows boot manager now directs to antergos and I can boot that without problems. However I cant boot windows now.
Gonna restore the EFI partition with my backup now.
That did not solve the problem, but I at least have a way to switch between win and antergos.