• Making changes persistent


    Hi guys,

    I am running Gnome and I am trying to change the behaviour of the Touchpad in my laptop. The idea is change the default three fingers for secondary button for two fingers and activate palm detection. I can achieve that so far with:

    synclient TapButton2=3

    synclient PalmDetect=1

    The problem is changes work through the terminal but they are not persistent. When the laptop is rebooted I lost all the changes. How can I make them persistent?

    Cheers.

  • @sophos1977 I am sure there is an easier / better way, but you could make a small script and then go to the session / startup settings of your DE and set it to run that script at login. I don’t use gnome, but can you edit those settings directly from the mouse and touchpad settings?

  • @Shryp said in Making changes persistent:

    @sophos1977 I am sure there is an easier / better way, but you could make a small script and then go to the session / startup settings of your DE and set it to run that script at login. I don’t use gnome, but can you edit those settings directly from the mouse and touchpad settings?

    0_1490563963419_raton.png

  • @Shryp Thanks for answering. I need to check how to do so in Gnome.

  • @judd How you can see in your own image there are no options for Touchpad. There is a workaround which fixes that deleting the synaptic file but after all there is no option for palm detection either. I think is maybe easier to use the option of the script.

    Cheers.

  • Hi again guys,

    I have created a small script with only two bash lines for the palm detection and change the secondary button. I have made it executable and copy it to ./configure/autostart but I did something obviously wrong because when I reboot the laptop the script doesn’t execute. Any idea will be really welcome.

    Cheers.

  • @sophos1977
    Did you add #!/bin/bash at the beggining of the file?
    If not, you’ll need to add the line above.
    Add please your script here (if is short) for us to take a look.

  • @fernandomaroto Yep, this is the script that I am using:

    #!/bin/bash
    
    synclient PalmDetect=1
    
    synclient TapButton2=3
    

    The fact is if I execute the script into the bash works perfectly.

    Thanks.

  • .config/autostart/NAMEXY.desktop
    

    should be the place for a .desktop file what do start your skript on startup of Gnome
    https://wiki.archlinux.org/index.php/Desktop_entries

    [Desktop Entry]
    Type=Application
    Exec=sh "/where/your/skript/is/saved/skript.sh"
    Hidden=true
    NoDisplay=true
    X-GNOME-Autostart-enabled=true
    Name[en_IN]=starterXY
    Name=starterXY
    Comment[en_IN]=
    Comment=
    
    

    Or use Arronax [yaourt -S arronax]

  • @joekamprad Thanks for the suggestions. I put the script in ./config/autostart but the script doesn´t execute automatically. Should be necessarily a .desktop file or it is enough with the script?

    Cheers.

  • I never needed to use a .desktop file, but i usually use the desktop’s startup app. Try to set through Gnome config, although i think your script should be working already.

  • i think gnome will only autostart the skript over a .desktop file!
    Because the procedure who reads the ./config/autostart/ only is powered to read files in .desktop scheme…
    Gnome is like that in many ways

  • @joekamprad ok,i didn’t know.

  • Hi there,

    I created a .desktop file with the following content:

    [Desktop Entry]
    Type=Application
    Exec=sh "/home/user/Documents/Touchpad Script.sh"
    Hidden=true
    NoDisplay=true
    X-GNOME-Autostart-enabled=true
    Name=Touchpad.desktop	
    Comment=
    Name[en_GB]=Touchpad.desktop
    

    Again, I can execute the file manually but it doesn’t start automatically after login.

    No idea what is going on guys.

    Cheers.

  • @sophos1977 Ok, Did you put the .desktop at .config/autostart folder?

  • /home/user/Documents/Touchpad Script.sh

    need to be something like:

    /home/user/Documents/Touchpad-Script.sh
    

    and:

    Name=Touchpad-Script
    Comment=
    Name[en_GB]=Touchpad-Script
    

    Name of the program the starter aka .desktop file starts…

  • @fernandomaroto Yes, the .desktop file is in .config/autostart but doesn´t start automatically after log in.

  • try this one

    [Desktop Entry]
    Type=Application
    Name=Touchpad Script
    X-GNOME-Autostart-enabled=true
    Exec=/home/user/Documents/Touchpad-Script.sh
    

    and make shure the Desktop Entry do NOT need to be executable, only your skript!

  • @sophos1977 Can this not be achieved using the xorg.conf file for the touchpad? (ie. the 50-synaptics.conf). Reference libinput wiki on arch or the older method with synaptics

changes4 making3 persistent1 Posts 21Views 3981
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.