• WF-2650 All in One Scanner don't work

    Hello i am new here and have to say one of the best distro i tested. Now using it as primary system on my machine.

    I have an Epson WF 2650 all in One connected to my fritz! Box via Wlan with the drivers from Epson Printer and Scanner works on .deb or .rpm based distros.

    Noe i installed trough package manager and some epson things from AUR but only print works scanner not found only my FHD Wevbcam:

    [[email protected] ~]$ scanimage -L
    device `v4l:/dev/video0' is a Noname FULL HD 1080P Webcam virtual device
    [[email protected] ~]$ sudo mc
    [[email protected] ~]$ uname -a
    Linux darevine-m248 4.10.5-1-ARCH #1 SMP PREEMPT Wed Mar 22 14:42:03 CET 2017 x86_64 GNU/Linux
    [[email protected] ~]$ 

    I can only setup the printer to cups web interface. If i try to add him it tells me error with print-utillity i am using gnome here.

    Thx for help.

    PS: iscan is also installed.

  • @darevine If you install “epson-injet-printer-escpr” from the AUR you should be able to install your printer.

  • Hello,

    yes but the scanner don’t works or cannot be found.

  • Did you install iscan-data in addition to iscan?

  • Hello,

    yes but don’t detect any scanner

  • Sorry to hear that. Those were the 3 programs I installed to get my WF-3640 to work; thought it would help you. You did cycle off/on the printer after installing the programs, right? If so, I can’t think of anything else.

  • Hello,

    don’t works and i cannot find the driver. I need this driver http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=DE&CN2=&DSCMI=52155&DSCCHK=1fb9b46e5dc12b9768f564934e6e643009ee7d3c but cannot find in AUR or in local Repo. The Files only in .deb or rpm format. I try other distro also not works but on an rpm or deb based distro with installing the packages from Epson works without problem. So what to do now?

  • The Link you provide is linking to iscan and iscan-data both aviable in normal repo…

    Open Printing says: epson-inkjet-printer-escpr works for your device:
    epson-inkjet-printer-escpr Driver is in AUR:
    Problems with epson scanner all in one exists:
    Wiki Say:
    For network (including Wi-Fi) scanners, install iscan and iscan-plugin-network (from AUR), then edit /etc/sane.d/epkowa.conf and add the line:

    net {IP_OF_SCANNER}
  • Hello,

    thx for reply i just do the steps right now will reboot and tell result soon thx for advise!

  • Hello,

    i solved the Problem my Firewall was prevent to access the Scanner xD now it works and i can choose the scanner.

    0_1490708507254_Bildschirmfoto vom 2017-03-28 15-39-48.png

  • Sehr schön!

scanner6 wf-26501 Posts 11Views 1809
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.