• Like 0

    Need pw to apply updates but did not set one on installing antergos


    Hi,
    I installed antergos without a pw, (XFCE) and the session starts automatically. Whatever file I look into to find a hypothetic pw that I might have set & forgotten, they all say “nologin”. But when I want to apply updates, suddenly a pw is required. Typing nothing does not help so I am stuck and don’t know what to do. I read pages and pages here about how to add a new user but that also requires a pw - which I don’t have. Do I really need to reinstall from scratch? Thx for your help;

  • Like 0

    can you type “passwd” in a terminal and change your password?

  • Like 0

    Thx Shrip - when I do that I have to type my CURRENT pw first - which I never set…

  • Like 0

    Sorry: Shryp

  • Like 0

    I was thinking maybe that would accept a blank password.

  • Like 0

    Nope, I tried.

  • Like 2

    Hi,

    Boot again with the antergos iso, chroot to your system using arch-chroot and then you will be able to change any password you want.

    If you don’t know how to do it please ask ;)

    Cheers!

  • Like 0

    @karasu Thx very much - I don’t know how to do that, very thankful for instructions.

  • Like 0

    Ok, try this:

    1. Boot with the usb iso
    2. Close cnchi
    3. Open a terminal
    4. sudo fdisk -l /dev/sda

    4 will show your partition layout. Post it here so we know how to procede.

    Cheers!

  • Like 0

    @karasu Thx very much. Before I do that (laptop not with me right now) one last question: if one chooses to install antergos without a pw then updates are not possible? No way to update without a pw, correct?

  • Like 0

    Hi,

    Antergos installation always asks for a password. What I do not remember if it enforces it or not (it should, so I’ll check this one).

  • Like 0

    @karasu said in Need pw to apply updates but did not set one on installing antergos:

    Hi,

    Antergos installation always asks for a password. What I do not remember if it enforces it or not (it should, so I’ll check this one).

    Nope, I was right and Cnchi enforces entering a password or you can’t continue (even if you set autologin). Are you sure you didn’t establish a password and now you don’t remember doing it?

    Please, try with whatever password you use normally :grimacing:

    Cheers!

  • Like 0

    @karasu - Thx so much. I tried all possible pws, none works. How is it then that the session opens without asking for a pw? I have other computers with antergos installed where I HAVE to write a pw before the session opens.

  • Like 0

    Hi,

    How is it then that the session opens without asking for a pw?

    Because you have lightdm set to autologin. When the installer asks for user/password it also shows a checkbox that, if activated, setups lightdm to autologin (I’m sure you activated it in this case).

    Cheers!

apply1 updates22 installing39 Posts 14Views 236
Log in to reply