• Stuck on black screen on boot


    Hi.

    Having a problem with my antergos installation.
    See the video
    https://goo.gl/photos/e4cxHkQUqvnYbgwD9
    It just gets stuck on this black screen with the cursor.
    Ctrl+Alt+F2 doesn’t work. Nor anything else really.

    I was getting some weird message at that point yesterday, about a disk with a UUID missing ( it is the SSD with the / partition ). And it would throw me on an emergency shell ( where the keyboard would not work ).
    After a couple of reboots, it started just fine.

    But today, it’s stuck there forever. I tried rebooting 5-6 times already. Tried the fallback option as well, it’s the same.

  • If it matters, tried to boot from a live usb, and again it gets stuck on a screen with a blinking cursor.

  • can be everything… defect hardware … Biosreset … defect filesystem…

    And you try everything to get started with liveisousb?
    Win10 is working?
    same SSD as Antergos ?

    Is a different liveusbsystem can be started for example systemrescuecd?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Can I add any flags in the boot command to go in a terminal somehow so I can troubleshoot it that way?

    I’ll try to get an ubuntu live usb so I can run memtest and try booting into ubuntu.

    The win10 installation is dead as well, but that’s for weeks now, since some weird update on win got stuck. I don’t use it anyway so I don’t mind. I think it’s unrelated, since I used my PC just fine yesterday for many hours.

    I changed hardware two days ago ( installed a new mobo with a Ryzen CPU ) and then got back to the old one yesterday, could that be the issue?

  • Usually Linux do not mind about hardware-changes Kernel loads mostly on demand…
    But may you do hardcoded changes related to hardware, or Bios settings are wrong
    some like Native-ide vs. Ahci…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Ubuntu live cd boots fine.
    Interesting point though.
    I have 3 SSDs. One of them has an NTFS partition and an EXT4 one, both for data. Those partitions are mounted in Ubuntu live automatically.
    Second SSD with NTFS, again loaded automatically.
    But it doesn’t mount any partition from the one that has the OSes ( it has 2 EXT4 for antergos, an NTFS for win10 and another windows related one )

    Does that mean that there’s some issue with the partitions that SSD?
    Any way to check?
    Would it help if I delete the ones for win10?

    If you notice the video at 0:13, I get some message about cleaning something.
    Starts with "/dev/sdc3/: recovering journal"
    What does that mean?

  • For Bootup to rescue shell: Type “e” when you see Antergos bootscreen and put a “1” between rw 1 quiet
    Bild Text

    If you have a systencrash or unclean shutdown system recover the filesysten automaticly…[Starts with “/dev/sdc3/: recovering journal”]

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad But I see it every time for the last few days/weeks, is that normal?

    Can I do fsck from the ubuntu live environment? To check there first.

  • Filesystemcheck: (unmount partition first!) You can do also from Ubuntu Life System-
    https://wiki.archlinux.org/index.php/Fsck

    sudo fsck.ext4 -v -f -c -y  /dev/sdX
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • So, fsck run on both the EXT4 partitions I use ( for / and /home ) no problems reported.

    I edited the “1” like you said, and I can go to a recovery shell right away.
    I can see my partitions mounted just fine.
    So seems that the SSD is fine.
    How can we see why it’s stuck to that cursor screen?

    Btw, here’s my boot "script"
    https://goo.gl/photos/uc12uwezfrfAsJAu7

    EDIT
    If I do journalctl -xe, I can see in the latest logs that “spawning /bin/plymouth failed”.
    Is that related to that boot error somehow maybe?

  • Seems to me that I have a similar problem
    http://www.linuxquestions.org/questions/linux-newbie-8/boot-hang-process-bin-plymouth-could-not-be-executed-4175590756/

    Likewise, I cannot find /bin/plymouth, and also none of the systemd services has plymouth.
    That guy ended up re-installing (!)
    Any ideas on how to solve this?

  • Software/Plymouth
    I do not think this error says something …
    plymouth is not installed or do you?

    what say:

    cat /etc/mkinitcpio.conf | grep plymouth
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • By digging more into journalctl, I see that this is from a rescue systemd service.
    On a normal boot ( the one that gets stuck ) I don’t get that. Actually the logs there look normal at the end.
    But, somewhere in the middle, there’s a weird “BUG” error.

    Look at those two screens
    https://goo.gl/photos/KMFmyBoDHedzEWvq5

    Could it be something related to the graphics card?
    I cannot understand what’s going on.

    EDIT
    cat /etc/mkinitcpio.conf | grep plymouth gives nothing.

  • Could be contact problem with the graphiccard…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • That was it. I have a PCI-e extender cable, where I connect the GPU.
    Plugged the GPU directly onto the motherboard, and I get normal boots every time…
    Damn cheap extension cables!

    Thanks for the help.

  • Just want to report on the issue.
    It was definitely the riser cable.
    Got a new one, and everything works perfectly.
    The CPU and the mobo are fine ( some slight audio issues, hopefully 4.11 will fix them )

black30 stuck19 boot148 Posts 16Views 560
Log in to reply