• Screen Tearing - Display Issues (choppy, tearing, etc)


    Thought I’d start a new thread as the other one kind of started as something else.

    First video is for the first example. I don’t have a tri-pod, but I don’t think that is the issue. It seems to be recording other artifacts on the screen that my eye can not see viewing the monitor. Not sure if that is normal.

    When I scroll the page it does occur, but the video makes it hard to see I think (my eyes are bad anyways). Let me know what you think but I am going to try and get better videos and different situations. https://vid.me/MiPu

    Here is another example of this issue.

    When viewing YouTube videos (at least 60FPS videos) they play fine in small view, so default. Once I go full screen they are choppy and slow. I hope this video can record what I am seeing. Now regular videos (not 60FPS) at full screen work better, but have a different screen issue, that I tried showing in the video above (related to scrolling pages)

    I have had these kind of graphic issues every time I have used Linux. There has to be someone to knows this and can fix this. It’s ridiculous. Here is that second video - https://vid.me/ejtv

    If anyone has any kind of idea/suggestion. Please. I will try to get more examples of this issue as well.

  • @noobertroon You forgot to mention the most important info: Which desktop environment are you using? :wink:
    In most cases you can solve the problem by using Compton, or an other display manager.

    Never to old to learn.

  • Bah. Cinnamon.

    I tried using Compton before and almost broke my system. I was told to try the Nvidia Settings first and turn on Full Pipeline or whatever it is called. Clearly that didn’t work.

  • Another weird thing. I have an xorg.conf file under /etc/X11/xorg.conf.d with the following details

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 378.13  (builduser@anthraxx)  Thu Feb 16 23:29:17 CET 2017
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "KJT HDMI4K2K60"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 980 Ti"
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-1"
        Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    

    I am hoping this may be my issues. If you look at the section with “HorizSync” and “VertiRefresh” it seems to be the refresh rate. My monitor is 60hz, yet none of those numbers are that.

    Also does this file look correct? Nothing weird

  • Can anyone help with this? To even just start, how do I make sure I am set and running at 60HZ?

  • And do you try without this xorg.conf? usually no need for xorg.conf
    Do you try to use the “Antergos-Nvidia-Installer” ???

    pacman -S nvidia-installer
    nvidia-installer -t
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Not sure what you mean by the nvidia installer? Is that the app for installing the latest drivers from the Add/Remove Programs app. then yes I used that to install my drivers.

    I have the Nvidia Drivers installed and am using the Nvidia Settings which is actually what created the xorg.conf file.

    But yes, I was using the system before that was created and the same issue occured.

  • what else you have then under /etc/X11/xorg.conf.d/:

    cd /etc/X11/xorg.conf.d/
    ls
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • 00-keyboard.conf  50-synaptics.conf  99-killX.conf  xorg.conf  xorg.conf.backup
    
  • I got problems here with using nvidia-settings anyway… and i think hat the way nvidia-settings is writing the xorg.conf is not compatible with archlinux anymore…
    As you can see you get a 00-keyboard.conf for example, the sections are handeld by there own .conf files. Where classic xorg.conf have all in one file, so you get double section entry for keyboard then…
    nvidia-seetings can also be set without xorg.conf like here:
    https://wiki.archlinux.org/index.php/NVIDIA#NVIDIA_Settings

    can you check inside terminal:

    echo $XDG_SESSION_TYPE
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • the output for that is x11

    You show a link about nvidia-settings, but I am using nvidia-settings, and you are saying not to use them? I may be confused. You mean that help post about nvidia-settings is not referring to the Nvidia Settings application?

    So what are you wanting me to do exactly?

  • "the way nvidia-settings is writing the xorg.conf " is what i mean to not using nvidia-settings…
    the link i provide shows howto enable nvidia-setting options without writing it to the xorg.conf.

    Wiki say also that: move the settings file to /etc/X11/xorg.conf.d/20-nvidia.conf where they will be loaded automatically
    So you can do this also

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • I guess I am asking for more detailed steps.

    Should I remove the nvidia-settings application, do I just rename the current xorg.conf file within the file browser, or in the terminal somehow? Should I rename all those files found under xorg.conf.d, so on and so on. Which order is best for example as well?

    Sorry, not that easy to me and I find those arch wikis not easy to understand. I suppose I may be asking a lot of you, i dunno. I will try to read that wiki and figure it out.

  • No no no there are no stupid questions here at Antergos ;)
    And ArchWiki is made from people with long time Linux practical knowledge experience… for thouse people…

    you can just rename your xorg.conf to 20-nvidia.conf this should work …

    sudo mv /etc/X11/xorg.conf.d/xorg.conf /etc/X11/xorg.conf.d/20-nvidia.conf
    

    do that job… rest of the .conf files under /etc/X11/xorg.conf.d/ will be o.k. and not effecting your graphics…

    And you do NOT need to uninstall nvidia-settings!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • But… i try to do so putting what nvidia-settings want to write inside my 20-nvidia.conf and i can not start X anymore…
    So is kind of what i say nvidia-settings does not fit… better to do not use it to write xorg.conf.d files…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Your last reply has confused me.

    Do you want me to run sudo mv /etc/X11/xorg.conf.d/xorg.conf /etc/X11/xorg.conf.d/20-nvidia.conf or no?

    That being said, all that does is disable that. As I said, when I had the fresh system, without the xorg.conf it was having the same issue.

  • I ended up running it. Issues still occur…

    Am I supposed to do something else now? That link to the Arch Wiki about Nvidia Settings. Not sure what I am supposed to be running exactly.

    nvidia-settings -q CurrentMetaMode
    

    And see what it says?

  • mostly everything you setup inside nvidia-settings (GUI) will be enabled immediately, but will be lost after rebooting.
    Both thinks are for automatic reload the settings, one way is to put inside the 20-nvidia.conf the other is to safe inside your homefolder ~/.nvidia-settings-rc and let them load at startup with the command nvidia-settings --load-config-only.

    This command:

    nvidia-settings -q CurrentMetaMode
    

    is (as title of the part in the wiki says) for setting up multiple monitors…

    The command:

    sudo mv /etc/X11/xorg.conf.d/xorg.conf /etc/X11/xorg.conf.d/20-nvidia.conf
    

    is moving [mv] xorg.conf to new filename 20-nvidia.conf aka renaming the file …

    But your problem seem to be comming from something else… as you say nothing changed with loading the nvidia tweaks…

    Can you just check cinnamon system settings and what it says about your monitor, may this is overwriting what you try to set with x11.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • For more investigation need to get some logs
    Please pastebin and post only links here https://pastebin.com/

    cat /var/log/Xorg.0.log
    dmesg
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Those are some cool commands :) The Display section of the Cinnamon settings shows my monitor as KJT 24" HDMI-0 which means nothing to me. I have a Korean Wasabi Mango monitor, and it’s 42" I believe (not 24"). It does display 3840x2160(16:9) in the resolution and Normal for Rotation. Nothing else there.

    First command - https://pastebin.com/SkA3fxcw
    Second command - https://pastebin.com/vxrwb083

choppy2 tearing6 display26 issues40 Posts 35Views 1801
Log in to reply