I installed two versions of Antergos - one with KDE plasma and the other with Gnome. I’m trying to access the Linux machine from my windows machine - through RDP. I did the following:

Install from package manager (add/remove software):
TigerVNC
xrdp-git

Ran these commands from the terminal as sudo:

vncserver     
(asks for password etc)
systemctl --user start [email protected]:1

systemctl enable xrdp.service
systemctl enable xrdp-sesman.service

systemctl start xrdp.service
systemctl start xrdp-sesman.service

Did the same thing on both my Antergos machines. In the KDE machine, I get the error message environment variable “HOME” is not set in the logs.

In the Gnome machine, I don’t see this error message and all the 3 services are running perfectly fine. I’m also able to login to the RDP session from Windows machine. But once I login, I see the below (attached) screen. All I have is 3 terminal windows to use. I don’t see any graphical interface. 0_1490209305453_2017-03-22.png

Can you please help getting this resolved for me on both my machines?