• kernel panic (no init found) since recent kernel update to 4.10.1


    Re: Kernel panic - not syncing: No working init found. after Kernel update

    Hi,

    I have exactly the same problem as indicated here (https://forum.antergos.com/topic/6332/kernel-panic-not-syncing-no-working-init-found-after-kernel-update). Already tried a lot in the last two days. There is a similar issue described in the arch linux forums.
    Have been done a lot via chroot as indicated in this thread here and on arch (https://bbs.archlinux.org/viewtopic.php?pid=1698961#p1698961).
    But for me, it already fails to load my efi partition (only as read-only). I think this is the main problem. Do I need to have write access to /sdc2 (efi)? Whenever trying to mount my efi partition, I do get feedback that it can only being mounted as read-only…
    mkinitcpio runs smoothly through but I assume the changes are not applied on /boot.
    I will check for the symlink again (did it already yesterday, but I will post the output here). I also tried downgrading/upgrading the kernel, running mkinitcpio over and over - no result.

    Thanks for your appreciated feedback!

  • in the post from BuZZ-dEE he find out that his problem comes up with a package error from feedreader
    It was a broken symlink and he solved by fixing this…
    Do you have feedreader installed? or your problem is another one…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad Thanks! Indeed, I have it installed. I just removed the package via chroot. Yet, my lib64 dir seems totally fine:

    [[email protected] lib64]# stat /usr/lib64
      File: /usr/lib64 -> lib
      Size: 3         	Blocks: 0          IO Block: 4096   symbolic link
    Device: 811h/2065d	Inode: 263144      Links: 1
    Access: (0777/lrwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
    Access: 2017-03-21 00:12:33.053025314 +0100
    Modify: 2016-12-06 00:43:55.000000000 +0100
    Change: 2017-03-21 00:12:32.933024928 +0100
     Birth: -
    [[email protected] lib64]# stat /usr/lib
      File: /usr/lib
      Size: 249856    	Blocks: 496        IO Block: 4096   directory
    Device: 811h/2065d	Inode: 263140      Links: 303
    Access: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
    Access: 2017-03-21 21:46:31.289302731 +0100
    Modify: 2017-03-21 21:46:31.269305897 +0100
    Change: 2017-03-21 21:46:31.269305897 +0100
     Birth: -
    
    

    Comparing dirs:

    [[email protected] lib64]# ls -la | grep total
    total 1402092
    [[email protected] lib64]# cd /usr/lib    
    [[email protected] lib]# ls -la | grep total
    total 1402092
    
    

    Should I try to recreate the symlink?

    While arch-chrooting, I also found a /boot - so it should be not needed to mount the efi partition manually, I guess?

    [[email protected] antergos]# arch-chroot /mnt/
    [[email protected] /]# pwd         
    /
    [[email protected] /]# ls /boot/
    efi   initramfs-linux-fallback.img  memtest86+  vmlinuz-linux
    grub  initramfs-linux.img           syslinux
    [[email protected] /]# pacman -Qs | grep reader
    local/feedreader 2.0.2-3 (rss)
        A simple feedreader desktop client for web services like Tiny Tiny RSS.
        An audio metadata tag reader and writer
        Standalone mail and news reader from mozilla.org
    

    If this this is of further help: running lsblk on live-image:

    [[email protected] ~]$ lsblk 
    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    0 465.8G  0 disk 
    ├─sda1   8:1    0   500M  0 part 
    └─sda2   8:2    0 465.3G  0 part 
    sdb      8:16   0 698.7G  0 disk 
    ├─sdb1   8:17   0  18.8G  0 part /mnt
    └─sdb2   8:18   0 679.9G  0 part 
    sdc      8:32   1  14.5G  0 disk 
    ├─sdc1   8:33   1   1.7G  0 part /run/archiso/bootmnt
    └─sdc2   8:34   1    31M  0 part 
    sr0     11:0    1   4.3G  0 rom  /run/media/antergos/TR_LEGEND
    loop0    7:0    0   1.6G  1 loop /run/archiso/sfs/root-image
    
    

    checking for symlink mismatches:

    [[email protected] lib64]# pacman -Qkk | grep warning
    warning: brother-dcp7040: /usr/share/brother/inf/brDCP7040rc (Modification time mismatch)
    warning: brother-dcp7040: /usr/share/brother/inf/brDCP7040rc (Size mismatch)
    warning: cups: /etc/cups/classes.conf (Permissions mismatch)
    warning: cups: /etc/cups/printers.conf (Permissions mismatch)
    warning: cups: /etc/cups/subscriptions.conf (Permissions mismatch)
    warning: filesystem: /root (Permissions mismatch)
    warning: google-chrome: /usr/share/applications/google-chrome.desktop (Modification time mismatch)
    warning: google-chrome: /usr/share/applications/google-chrome.desktop (Size mismatch)
    warning: grub: /boot/grub/grub.cfg (Permissions mismatch)
    warning: grub: /etc/grub.d/10_linux (Permissions mismatch)
    warning: java-runtime-common: /usr/lib/jvm/default (Symlink path mismatch)
    warning: java-runtime-common: /usr/lib/jvm/default (Modification time mismatch)
    warning: java-runtime-common: /usr/lib/jvm/default-runtime (Symlink path mismatch)
    warning: java-runtime-common: /usr/lib/jvm/default-runtime (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.alias (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.alias.bin (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.builtin.bin (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.dep (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.dep.bin (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.devname (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.softdep (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.symbols (Modification time mismatch)
    warning: linux: /usr/lib/modules/4.10.4-1-ARCH/modules.symbols.bin (Modification time mismatch)
    warning: networkmanager: /etc/NetworkManager/system-connections (Permissions mismatch)
    warning: nfs-utils: /usr/share/doc/nfs-utils (Permissions mismatch)
    warning: openvpn: /run/openvpn-client (No such file or directory)
    warning: openvpn: /run/openvpn-server (No such file or directory)
    warning: os-prober: /usr/lib/os-probes/50mounted-tests (Modification time mismatch)
    warning: os-prober: /usr/lib/os-probes/50mounted-tests (Size mismatch)
    warning: packagekit: /var/lib/PackageKit/transactions.db (Permissions mismatch)
    warning: qtcurve-qt5: /usr/share/kstyle/themes/qtcurve.themerc (No such file or directory)
    warning: smbnetfs: /etc/smbnetfs/.smb (UID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb (GID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smb.conf (UID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smb.conf (GID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smbnetfs.auth (UID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smbnetfs.auth (GID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smbnetfs.conf (UID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smbnetfs.conf (GID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smbnetfs.host (UID mismatch)
    warning: smbnetfs: /etc/smbnetfs/.smb/smbnetfs.host (GID mismatch)
    warning: vlc: /usr/lib/vlc/plugins/plugins.dat (Modification time mismatch)
    warning: vlc: /usr/lib/vlc/plugins/plugins.dat (Size mismatch)
    warning: whatsie: /opt (Permissions mismatch)
    warning: whatsie: /usr (Permissions mismatch)
    warning: whatsie: /usr/share (Permissions mismatch)
    warning: whatsie: /usr/share/applications (Permissions mismatch)
    warning: whatsie: /usr/share/icons (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/128x128 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/128x128/apps (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/16x16 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/16x16/apps (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/24x24 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/24x24/apps (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/256x256 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/256x256/apps (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/32x32 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/32x32/apps (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/48x48 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/48x48/apps (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/512x512 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/512x512/apps (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/64x64 (Permissions mismatch)
    warning: whatsie: /usr/share/icons/hicolor/64x64/apps (Permissions mismatch)
    
    

    so there are some warnings about the kernel + grub. Not sure if this gives any hint?!

    edit: as I read everywhere about mounting the /boot dir manually - how can I figure out my efi partition? According to this, my efi partition should be sdc2, right?

    [[email protected] ~]$ blkid 
    /dev/sda1: LABEL="System Reserved" UUID="E6869A4F869A1FDB" TYPE="ntfs" PARTUUID="771c5185-01"
    /dev/sda2: UUID="347A9C2B7A9BE83E" TYPE="ntfs" PARTUUID="771c5185-02"
    /dev/sdb1: LABEL="root" UUID="6b10577c-a0d2-4742-9f30-842926144e95" TYPE="ext4" PARTUUID="c9ebd329-5417-44cd-a17b-314c786b02ed"
    /dev/sdb2: LABEL="home" UUID="08ea7be6-a20b-4b72-a64f-8e9f6ae1bea8" TYPE="ext4" PARTUUID="e8162548-0fe3-4a8e-80a3-d706b607bc7f"
    /dev/sr0: UUID="2014-02-19-13-33-00-00" LABEL="TR_LEGEND" TYPE="iso9660"
    /dev/sdc1: UUID="2016-09-25-15-55-35-00" LABEL="ANTERGOS" TYPE="iso9660" PTUUID="4b81b827" PTTYPE="dos" PARTUUID="4b81b827-01"
    /dev/sdc2: SEC_TYPE="msdos" LABEL="ARCHISO_EFI" UUID="17C6-BA1D" TYPE="vfat" PARTUUID="4b81b827-02"
    /dev/loop0: TYPE="squashfs"
    

    so I tried it with mounting sdc2 in /mnt/boot/efi
    I successfully run mkinitcpio and then I want to create the grub config file but get the following error:

    [[email protected] /]# grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Found theme: /boot/grub/themes/Antergos-Default/theme.txt
    Found linux image: /boot/vmlinuz-linux
    Found initrd image: /boot/initramfs-linux.img
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img
    ERROR: mkdir /var/lock/dmraid
    ERROR: mkdir /var/lock/dmraid
    ERROR: mkdir /var/lock/dmraid
    ERROR: mkdir /var/lock/dmraid
    ERROR: mkdir /var/lock/dmraid
    ERROR: mkdir /var/lock/dmraid
      WARNING: Failed to connect to lvmetad. Falling back to device scanning.
    grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your device.map.
    Found memtest86+ image: /boot/memtest86+/memtest.bin
    done
    
    

    edit2: fixed it last night after trying over and over the above mentioned actions. Maybe having removed feedreader and re-run the symlink creation helped - hard to say. FYI I did not have to mount my efi partition manually in chroot - it worked without.

kernel panic3 kernel update4 boot148 bootefi6 Posts 3Views 279
Log in to reply