• Like 0

    A Few Issues


    Just did a fresh install and I am already having issues (Antergos Cinnamon)

    Two programs that I had no problems with last time around are having issues.

    Syncthing and Redshift are not being added to the Startup Applications list. Each program has the option within their settings to do this. Last time, that worked. They aren’t this time. Even if I add them manually to the Startup Application GUI its not saved. I close it, go back to it and they are already removed.

    I have done nothing to the system besides install all my apps and the latest Nvidia drivers. Are there logs that I can get that might be helpful?

    Ideas/suggestions?

  • Like 0

    Sorry to do this but it is really bothering me as it makes no sense.

    Are there any logs, any settings that could cause issues like this, anything at all I could check?

  • Like 0

    You can create script to run them…
    I use redshift here, but i use i3-wm so i just set it to exec redshift.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    A good idea to get it working, but disappointing as it should already be working.

    Any inklings on how to do that for cinnamon (scripts). I will do some searching though. Thanks

  • Like 0

    @noobertroon I don’t use cinnamon, you’ll need to play a little on it to discover how it works for you.
    Usually there is “startup config” at configurations; then you add the program you want to start

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    Apparently not that many people use Cinnamon as so far no luck on how to add items.

    Probably because Settings > Startup Applications is how you do it but that is what is not currently working.

  • Like 0

    @noobertroon
    ok, maybe in the command option you can add the full path like:
    /usr/bin/redshift

    Not sure about syncthing but probably the same:
    /usr/bin/syncthing

    Or the path to the script you made:
    /PATH/script_name

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 0

    I’m sorry if we are going in circles.

    When you say the command option you are referring to the Startup Applications area. The issue isn’t being able to add an item to the startup list. It’s that once you close out that app and go back, they have been removed. It isn’t saving anything.

    Unless I have misunderstood you.

  • Like 0

    @noobertroon
    Ah yes, it’s been a time since i read your first post, didn’t remember.
    So, i don’t know what else you can do, sorry.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Like 1

    So I still have no idea why this issue occurred but I got it to work.

    I found out about .desktop files and also found the startup folder. That folder being /etc/xdg/autostart

    I then looked at the files that were already in there and basically copied them. Here is my one for redshift.

    [Desktop Entry]
    
    Name=redshift
    Comment=Redshift Tray Icon
    Exec=redshift-gtk
    Terminal=false
    Type=Application
    StartupNotify=false
    NoDisplay=true
    NotShowIn=GNOME;KDE;Unity;
    Name[en_CA]=redshift-gtk.desktop
    

    So the issue is still there, this is a workaround. But still, happy now.

issues28 Posts 10Views 231
Log in to reply