• Cannot install via pacamXG or pacman.


    When I try installing any software; I get after downloaded packages is; ERROR improper NULL argument, installation aborted.

  • When I try installing any software; I get after downloaded packages is; ERROR improper NULL argument, installation aborted.

  • Hmmm…is that everything contained in the error? Could you copy and paste everything here from when you try using pacman in the terminal?

  • $ sudo pacman -Syu

    :: Synchronizing package databases…
    core 4.2 KiB 13.8K/s 00:00 [########################################] 100%
    core.sig 4.2 KiB 15.0K/s 00:00 [########################################] 100%
    extra 4.2 KiB 15.1K/s 00:00 [########################################] 100%
    extra.sig 4.2 KiB 14.5K/s 00:00 [########################################] 100%
    community 4.2 KiB 13.4K/s 00:00 [########################################] 100%
    community.sig 4.2 KiB 13.9K/s 00:00 [########################################] 100%
    antergos is up to date
    multilib 4.2 KiB 14.1K/s 00:00 [########################################] 100%
    multilib.sig 4.2 KiB 14.9K/s 00:00 [########################################] 100%
    multilib 4.2 KiB 14.1K/s 00:00 [########################################] 100%
    multilib.sig 4.2 KiB 15.2K/s 00:00 [########################################] 100%
    :: Starting full system upgrade…
    warning: automake: local (1.13.2-1) is newer than core (1.13.1-1)
    warning: ca-certificates: local (20130119-2) is newer than core (20130119-1)
    warning: cracklib: local (2.8.22-2) is newer than core (2.8.22-1)
    warning: cronie: local (1.4.9-4) is newer than core (1.4.9-2)
    warning: fakeroot: local (1.19-1) is newer than core (1.18.4-1)
    warning: glib2: local (2.36.2-1) is newer than core (2.36.1-3)
    warning: gnupg: local (2.0.20-2) is newer than core (2.0.19-7)
    warning: groff: local (1.22.2-3) is newer than core (1.22.2-2)
    warning: hwids: local (20130512-1) is newer than core (20130228-1)
    warning: inetutils: local (1.9.1-5) is newer than core (1.9.1-4)
    warning: iputils: local (20121221-2) is newer than core (20121221-1)
    warning: jfsutils: local (1.1.15-4) is newer than core (1.1.15-3)
    warning: kbd: local (1.15.5-4) is newer than core (1.15.5-3)
    warning: keyutils: local (1.5.5-4) is newer than core (1.5.5-3)
    warning: krb5: local (1.11.2-4) is newer than core (1.11.2-1)
    warning: libcap: local (2.22-5) is newer than core (2.22-4)
    warning: libldap: local (2.4.35-3) is newer than core (2.4.35-2)
    warning: libsasl: local (2.1.26-2) is newer than core (2.1.23-10)
    warning: linux: local (3.9.3-1) is newer than core (3.9.2-1)
    warning: logrotate: local (3.8.4-2) is newer than core (3.8.4-1)
    warning: man-db: local (2.6.3-3) is newer than core (2.6.3-1)
    warning: mdadm: local (3.2.6-4) is newer than core (3.2.6-3)
    warning: pam: local (1.1.6-4) is newer than core (1.1.6-3)
    warning: pciutils: local (3.2.0-3) is newer than core (3.2.0-2)
    warning: pcmciautils: local (018-7) is newer than core (018-6)
    warning: procps-ng: local (3.3.7-2) is newer than core (3.3.7-1)
    warning: sudo: local (1.8.6.p8-2) is newer than core (1.8.6.p8-1)
    warning: systemd: local (204-2) is newer than core (204-1)
    warning: systemd-sysvcompat: local (204-2) is newer than core (204-1)
    warning: sysvinit-tools: local (2.88-10) is newer than core (2.88-9)
    warning: util-linux: local (2.23-2) is newer than core (2.23-1)
    warning: wireless_tools: local (29-8) is newer than core (29-7)
    there is nothing to do

    $ sudo pacman -Syy
    :: Synchronizing package databases…
    core 4.2 KiB 14.5K/s 00:00 [########################################] 100%
    core.sig 4.2 KiB 14.1K/s 00:00 [########################################] 100%
    extra 4.2 KiB 13.9K/s 00:00 [########################################] 100%
    extra.sig 4.2 KiB 15.0K/s 00:00 [########################################] 100%
    community 4.2 KiB 5.21K/s 00:01 [########################################] 100%
    community.sig 4.2 KiB 15.3K/s 00:00 [########################################] 100%
    antergos 38.4 KiB 62.3K/s 00:01 [########################################] 100%
    multilib 4.2 KiB 14.1K/s 00:00 [########################################] 100%
    multilib.sig 4.2 KiB 14.6K/s 00:00 [########################################] 100%
    multilib 4.2 KiB 15.1K/s 00:00 [########################################] 100%
    multilib.sig 4.2 KiB 14.1K/s 00:00 [########################################] 100%

    sudo pacman -S openbox
    resolving dependencies…
    looking for inter-conflicts…

    Packages (4): imlib2-1.4.5-4 libid3tag-0.15.1b-7 startup-notification-0.12-3 openbox-3.5.0-7

    Total Download Size: 0.91 MiB
    Total Installed Size: 4.22 MiB

    :: Proceed with installation? [Y/n] Y
    :: Retrieving packages …
    startup-notification-0.12-3-x86_64 4.3 KiB 14.0K/s 00:00 [########################################] 100%
    libid3tag-0.15.1b-7-x86_64 4.2 KiB 13.3K/s 00:00 [########################################] 100%
    imlib2-1.4.5-4-x86_64 4.2 KiB 10.6K/s 00:00 [########################################] 100%
    openbox-3.5.0-7-x86_64 4.2 KiB 14.7K/s 00:00 [########################################] 100%
    (4/4) checking keys in keyring [########################################] 100%
    (4/4) checking package integrity [########################################] 100%
    error: failed to commit transaction (wrong or NULL argument passed)
    Errors occurred, no packages were upgraded.

  • Did you install testing packages? I will assume yes because of all that warnings

    Did this start to happend after using testing?

  • This is fresh install, Testing is commented out. Google claims slow internet, corrupted packages, broken packages. Tried all mentioned no solution yet.

  • Hm… I just saw that it is like if you were getting the databases from at out of sync mirror, for example keyutils was updated 17/May to 1.5.5-4 but pacman is telling you that your current keyutils is newer than the keyutils pacman finds on the database which is 1.5.5-3

    Try switching to another mirror editing /etc/pacman.d/mirrorlist

    Remove also your cache completely with: sudo pacman -Scc
    And sync: sudo pacman -Syy

    Try now to install something

  • You got it right.

    Thanks

Posts 8Views 2395
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.