• Upgrade issue


    Thanks to @fernandomaroto who kindly informed me to post a new topic.

    So, as I tried to tell in issue “Error in installing latest updates! please need help”, the UI my antergos PC won’t start after the login. I had already experienced the issue of not being able to update the ca-certificates package. I updated many other packages by just deselecting the two certificate packages.

    Then yesterday I bumped into the mentioned issue and the advice in the posts in that thread. So executed the command “pacman -Syu --force”. Everything looked good. Then I rebooted, but after login, the screen remained black. However, I could open a virtual terminal and try other updates and tricks. I have mainly used Fedora earlier and Antergos is so much different…

    My login manager is “lightdm”. I tried to use gdm according to some posts in this forum, but that didn’t work at all better. Desktop manager is anyway Gnome.

    I have had difficulties earlier also with Antergos updates, but not as drastic as this certificate update.

    Any help is greatly appreciated!

  • @vpp21 I followed the same instruction & had a black screen with a game in Wine. Yesterday I did a new update & all was fixed & working again. Try doing that & see if the thing that is causing your issue is fixed.

    Good luck.

  • Hi @Uzi, thanks for your encouragement!

    What did you exactly update? I have just tested, if new updates are available with commands like “pacman -Su” and “pacman -Syu” to no avail.

    I don’t know pacman too well yet. I come from yum and rpm world. I cannot even check what has been installed in my PC… :)

    Yesterday I checked the pacman.log shortly, but I didn’t find anything else suspicious there except that two hardware drivers were missing. I suppose I had never seen that warning earlier on screen while updating. In the evening I can find out the names of the HW resources mentioned in pacman.log, in case those names ring any bell.

    Well, now I remembered another odd thing in the log: there was a long sequence of NULLs somewhere close to the end of the log. I wonder, if there had been an internal issue in pacman?!

  • Can you post that log to paste2.org (or a similar service) and post the link here so we can see it?

    Cheers!

  • Sure!

    But only after about 12 hours. That is, in the evening locally.

  • @vpp21 I “sudo pacman -Syu” every Thursday after backup & it has served me well for a couple of years with antergos. If ever there is something not working right repeating a day or 2 later usually fixes it after Karasu works his magic or those at Arch do. This is what happened after doing it yesterday.

    I see @karasu is on the case so you will get sorted. Welcome to Antergos. You wont be leaving :smirk:

  • I am really hoping so. The PC I am currently using is a pretty new one assembled by my sons. It has the latest tools for my hobby: digitizing my analogue music. It is so quick. But it hangs up maybe once a week.

    If I cannot get it up, I may resort to my old warhorse, Fujitsu-Siemens Scaleo P with Fedora 10… :) It works like magic, just slowly, though. But never freezes. I wonder, if Jubbler still exists or is buildable in any distribution? It can be used for creating or fixing subtitles for videos.

  • Ok, now I’m back at my PC, but since I cannot make the PC recognize my thumb drive, I have trouble sending the pacman.log out of this PC. Any workaround?

    Other than that, I was able to update all that was offered today, but it had no effect on my issue. UI remains black.

  • Now that I cannot do much I can tell something about what I have seen in pacman.log.

    ALPM-SCRIPTLET:

    WARNING: Possibly missing firmware for module: aic94xx
    WARNING: Possibly missing firmware for module: wd719x

    Unknown media type in type 'all/all’
    Unknown media type in type ‘all/allfiles’

  • If you get internet connection and still can install programms:

    sudo pacman -S pastebinit
    

    lets you send anything you want directly to a pastebin from the command line.

    pastebinit -i  /where/your/logfile/is
    
    

    will give you a pastebin url you can write down on paper also ;)

    like this:

    http://pastebin.com/NkEdaL3v
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • this is not a textfile it is binaric ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • It will be a zip file. As text, the size would have been too big.

  • but pastebin does not understand zip files only text and it is not a problem what could this be a 150kb file?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • You should be able to download the file by selecting “raw” download. It should create a file <link>.zip in your PC.

  • true! it is intact ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • paste2 can do:

    pastebinit -b paste2.org -i pacman.log
    

    http://paste2.org/U3pJfXm6

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Do you have nvidiagraphics?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I was asked a few weeks back why I mentioned in a post doing a fresh install - if I had this issue, that is what I would do now. Some people love problem solving issues like yours, me, I like to make it go away so I can get back to enjoying my Antergos.

    Btw, I keep all my important stuff on a separate drive & copy .folders like .kodi, .thunderbird etc over before the reinstall, then its just a case of reinstalling my goodies again.

    Imagine doing that with Windows :smirk:

  • @joekamprad Good morning!

    The PC has a GeForce GT 730 graphics card. So I would expect it to use nvidiagrahics.

    @uzi Good morning to you too!

    I wouldn’t surrender at this point!? It would require too much time to install and build all those tools I need for my hobby once again. It was enough to first install Fedora and Mint and see they didn’t work. Albeit the issue with them probably lied in the old graphics adapter. Finally resorted to Antergos, which had all tools available right away to build and install additional tools. This made a difference and I was immediately hooked.

    I would really like to see how this is fixed in order to probably know the trick in case it happens again.

upgrade42 Posts 71Views 6664
Log in to reply