• MacBook Pro 2011 15" - still black screen on startup


    I went through the steps listed at
    wiki/install/installing-antergos-on-a-macbook-82-mid-2011/

    Open up a terminal
    Switch to root user using su
    Mount the partition in which you have Antergos installed, on the /mnt folder.  You can do it by using: mount /dev/sdXn /mnt with the X being the letter of your drive, and the n being the number of the partition.
    Change the root using arch-chroot /mnt. This open some kind of root session on that drive, allowing you to make changes to the system without booting from it.
    Uninstall lightdm, and install gdm: 
    pacman -Rcns lightdm
    pacman -S gdm
    systemctl -f enable gdm

    But still I see just the blank screen when it passes the antergos boot screen. Can you please help?

  • @tcsekhar Assuming you mounted the partition properly that should have worked…
    When you try to boot normaly and the screen get black, can you access tty2 or other with Ctrl+Alt+F2 (3,4,etc)?
    If so, can you login in and try the commands bellow just in case you installed on another mounted point?
    pacman -S gdm
    systemctl -f enable gdm

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Maybe you have tried, but i have had the same problem with a 2012 MBP and simple lightning the screen with the screen brightness keys did the trick. Stupid, but in my case after install and first boot, screen brightness was at 0. Also be sure no second screen is connected during boot, gives two black screens with sometimes only a mousecursor.

    Big change that this isn’t the “solution” for your computer, but anyway i post it.

  • Thank you for your responses.

    Tried the brightness setting (I don’t have any second monitor connected), but doesn’t make any difference.

    I don’t know what the tty2 is… I tried Ctrl+Alt+F2 and till F12. Nothing gets me to the terminal.

    I tried to do the arch-chroot on all other /dev/sdaX /mnt ==> but it works only on one, and I have executed the gdm install and enable commands but doesn’t help.

  • @tcsekhar then i guess is not problem with any of those packages…
    Maybe is something related to Macbook. Have you tried to search for Macbook posts in the forum?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • The article you refere to, deals with the MBP mid 2011. Are you sure your machine is from that generation, maybe your machine is the late 2011 model. Don’t know if there is a big difference between them, but have you tried to install Antergos the normal way, without the workaround. Maybe that’s the problem.

  • I did a clean install and then tried these steps. One thing I did differently this time is not enabled the Proprietary Graphics option in the installer.

    After running the above steps, its working fine now. Thank you so much for all your help.

  • @tcsekhar Good!
    Yes, normally when you install Antergos the Proprietary Graphics option is enabled by default, at least on my Mac (Intel+Nvidia). So, is it right that your Mac computer has only an Intel graphics card and no Nvidia (or ATI) one?

  • @bartatantergos Yes, thats correct. My MacBook has only one graphics card.

20111 black30 pro9 macbook16 Posts 9Views 436
Log in to reply