• Error in installing latest updates! please need help.


    can anyone please help.
    this morning i tried to update using -Syu command. all packages downloaded but cant install . it gives me this error.
    what to do?

    :: Proceed with installation? [Y/n] y
    (120/120) checking keys in keyring                   [############################] 100%
    (120/120) checking package integrity                 [############################] 100%
    (120/120) loading package files                      [############################] 100%
    (120/120) checking for file conflicts                [############################] 100%
    error: failed to commit transaction (conflicting files)
    ca-certificates-utils: /etc/ssl/certs/ca-certificates.crt exists in filesystem
    Errors occurred, no packages were upgraded.
    
  • Okay apparently linking to other forum posts is now considered “spam” 😕
    Go to the “announcements” section of the forum and find the thread labeled: “ca-certificates-utils-20170307-1-upgrade-requires-manual-intervention” and follow the instructions there.

    P.S. The main Arch site has been down for several hours now. (Which is very odd because I was told in IRC that Arch’s site is “even more reliable than Google,” which might have been trolling – who knows.)

  • @fernandomaroto has prepared a good collection of different threads that answer the question, for those who don’t want have time neither read nor search the forum.

  • thanks alot. i went to this below thread.

    https://forum.antergos.com/topic/6337/ca-certificates-utils-20170307-1-upgrade-requires-manual-intervention/4

    and used force command.
    sudo pacman -Syu --force

    now it is resolved. thanks

    i m sorry guys. i am newbie. i am new to undestand when such type of errors or conflicts happen during upgrade in arch based distros.

    i will remember the above --force command.

    many thanks.

  • @Sam-N said in Error in installing latest updates! please need help.:


    i will remember the above --force command.

    No, don’t remember it It’s safer to forget about it.

    It may be potentially dangerous. If a system is almost clean and stable, if there are no other issues except the only one, then --force may help to solve it.

    If there are some other issues in the system, then --force will silently “fix” them all - with unpredictable results.

    As with any Arch upgrade, --force must not be used blindly. The user must have a clear idea about what will be --force’d, before applying it.

    many thanks.

    You’re wlcome. Thanks for marking the topic as [Solved].

  • For me, using the --force option resolved the issue of certificates not being updated, but another came up. After logging in, there is no screen. That is, the screen remains black. I can hear the disk, so something is executed, probably updates checked, but the screen remains black. So I cannot do much with this system.

    I have able to use a virtual screen (text mode), but nothing else.

    Any ideas where my UI is hidden?

  • @vpp21 i Guess you should open a new topic about it, describe the problem, which Login Manager and Desktop you use for a start…

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Thanks @fernandomaroto!

    I have difficulties understanding this posting interface. How to eventually post the written new issue? I see no promising object…

  • @vpp21
    THIS is one way to create a new topic

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @vpp21 said in Error in installing latest updates! please need help.:

    Thanks @fernandomaroto!

    I have difficulties understanding this posting interface. How to eventually post the written new issue? I see no promising object…

    If you’re asking how to start a new topic, then it’s pretty simple.

    1. While reading any post, press the Home button, to scroll up to the top of a topic. There’s the HOME screen button in the upper left corner. Click it.
      0_1489958341867_antergos-forum-new-topic-1920x0180-1.png

    2. The forum’s home page opens, with the list of all available forums. Select one suitable for your question, e.g., Newbie Corner, and click its title.
      0_1489958458731_antergos-forum-new-topic-1920x1080-2.png

    3. The list of all posts in selected forum opens. There’s NEW TOPIC screen button in the upper left corner. Click it.
      0_1489958558016_antergos-forum-new-topic-1920x1080-3.png

    4. The form to compose a new post opens in the lower part of the browser’s window. Type in the subject, the post, click ASK AS QUESTION button. Or DISCARD, to abandon all changes.
      0_1489958751887_antergos-forum-new-topic-1920x1080-4.png

    5. Done

  • OK, now I see what I miss in this tablet interface. I have no way to enter the subject/title, so the Ask button does not work. If I cannot resolve this today, I will create the issue tomorrow. Thanks guys!

error279 installing102 updates52 help18 Posts 11Views 1596
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.