• Problems installing, cannot refresh databases.


    Hello,

    I’ve been trying to install Antegros for several hours now and I keep getting this same error (and sometimes another error that I failed to document) I keep getting the “Can’t refresh pacman databases” whether I have additional packages selected for installation or not. I’ve included a screenshot of the error I keep getting for additional details, any help will be greatly appreciated!

    screenshot error message: 520678

  • It sounds like the mirror you are trying to connect to is no longer active.

  • @Shryp said in Problems installing, cannot refresh databases.:

    It sounds like the mirror you are trying to connect to is no longer active.

    How can I select an alternative mirror?

  • Hi @notarobot ,

    That is an old Cnchi version, so it’s clear mirrors are not working for you (if they worked Cnchi would be able to update itself).

    Can you run in a terminal sudo pacman -Syy and post the results here?

  • @karasu said in Problems installing, cannot refresh databases.:

    Hi @notarobot ,

    That is an old Cnchi version, so it’s clear mirrors are not working for you (if they worked Cnchi would be able to update itself).

    Can you run in a terminal sudo pacman -Syy and post the results here?

    Here is the results of that command…

    [[email protected] ~]$ sudo pacman -Syy
    error: could not register 'multilib' database (database already registered)
    :: Synchronizing package databases...
     antergos                 144.2 KiB   540K/s 00:00 [######################] 100%
     core                     123.6 KiB   787K/s 00:00 [######################] 100%
     extra                   1678.7 KiB  2.46M/s 00:01 [######################] 100%
     community                  3.8 MiB  1976K/s 00:02 [######################] 100%
    multilib 176.5 KiB 6.63M/s 00:00 [######################] 100%
    
  • I’m still getting this same problem, if anyone could help me I would appreciate it very much. Thanks!

  • Hi,

    Sorry, don’t know what happened but I didn’t see your first answer…

    OK. The update works, try to update mirror list and cnchi next:

    sudo su
    pacman -Syy
    pacman -S pacman-mirrorlist antergos-mirrorlist
    cd /etc/pacman.d
    cp mirrorlist.pacnew mirrorlist
    cp antergos-mirrorlist.pacnew antergos-mirrorlist
    

    if it complains about mirrorlist.pacnew not found (or antergos-mirrorlist.pacnew not found) do not worry, just go on.

    cp mirrorlist mirrorlist.backup
    rankmirrors -n 10 mirrorlist.backup > mirrorlist
    pacman -Syy
    pacman -S cnchi
    

    Then, you can try to reinstall again, running:

    cnchi -dv --disable-rank-mirrors
    

    Cheers!

  • @karasu

    Thanks for all your help but I still can’t get it to install. I’ve tried the commands you posted and I’ve researched this issue as much as I can and I just can’t seem to find a solution. I have dumped the terminal activity from cnchi so you or someone else can view it…

    http://paste2.org/h1AwY7A9

  • Hi,

    Can't find these packages: lib32-mesa-libgl

    That’s an old bug. I do not know why you can’t update Cnchi.

    Anyway, you can try to patch Cnchi yourself.

    Run this:

    su
    find /usr/share/cnchi -type f -print0 | xargs -0 sed -i 's/lib32-mesa-libgl/lib32-mesa/g'
    

    And then run cnchi:

    cnchi -dv
    

    https://forum.antergos.com/topic/6342/cannot-create-donwload-package-list-metalinks/16

  • @karasu said in Problems installing, cannot refresh databases.:

    Hi,

    Can't find these packages: lib32-mesa-libgl

    That’s an old bug. I do not know why you can’t update Cnchi.

    Anyway, you can try to patch Cnchi yourself.

    Run this:

    su
    find /usr/share/cnchi -type f -print0 | xargs -0 sed -i 's/lib32-mesa-libgl/lib32-mesa/g'
    

    And then run cnchi:

    cnchi -dv
    

    https://forum.antergos.com/topic/6342/cannot-create-donwload-package-list-metalinks/16

    Thanks! That fixed the install problem.

installing102 refresh25 databases4 Posts 10Views 2647
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.