• Fresh installed VM bugs 1 pacman sync/db error


    Hi! i found 2 bugs now, which make extremelly boring to use the system till its fixed, i’ll create a second post to not mix stuffs…

    I’ts happening in a VM, not sure about RM

    1. the command sudo pacman -Syu and sudo pacman -Syyuu doens’t work. The terminal display a message about /var/lib/pacman/db.lck. At first i had to follow the error instructions to remove the mentioned file and then sudo pacman -Syyuu works.
      After reboot sudo pacman -Syyuu need to be executed in order to make sudo pacman -Syu work.
      Every reboot need to do the same (remove the package only the first time)

    Interesting that /var/lib/pacman/db.lck doens’t exist on my real pc, is this something new?

    Cheers!

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • db.lck is just a temp file pacman creates when it is working. It is so you can’t run the update twice at once. Are you sure you didn’t maybe have the GUI updater running at the same time?

  • i just login the machine and try to use pacman trough terminal… I’ll check again soon

    EDIT: ok, now worked, not sure if i tried to use the terminal while pamac/pamac tray was loading at startup… is this possible? (i rebooted 3 times and get the same errors before)

    So i guess that’s fine…
    Thanks for your attention.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

fresh26 bugs6 Posts 3Views 288
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.