• Login screen on wrong monitor


    This is my current monitor setup
    0_1489785566523_monitor-setup.png

    Whenever I first load up however, the login screen is on DP-2, and it treats the monitor setup as if they were in a line, like if the setup was like this…

    DP-2 | HDMI-1 | DP-3
    

    How do I get the login screen to use my applied monitor setup that is in the picture?

  • If you are using standard LightDM + lightdm-webkit-greeter you should pass this to lightdm…
    https://wiki.archlinux.org/index.php/LightDM#LightDM_displaying_in_wrong_monitor
    LightDM displaying in wrong monitor
    If you are using multiple monitors, LightDM may display in the wrong one (e.g. if your primary monitor is on the right). To force the LightDM login screen to display on a specific monitor, edit /etc/lightdm/lightdm.conf and change the display-setup-script parameter like this:

    /etc/lightdm/lightdm.conf
    display-setup-script=xrandr --output HDMI1 --primary

    Replace HDMI1 with your real monitor ID, which you can find from xrandr command output.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad So I uncommented the #display-setup-script= and changed it to display-setup-script=xrandr --output DP-3 --primary.
    After doing that, I rebooted but the login screen never appeared. Instead, all three monitors were what looked like terminals with the cursor blinking.
    Would’ve responded quicker but after that happened I had to figure out how to mount the encrytped drive on my live usb & edit the file back to how it was.

    I’m guessing the --ouput DP-3 isn’t correct, but I’m not sure what else to put there. When I run xrandr --listmonitors it gives me this…
    0_1489799385027_xrandr_listmonitors.png

  • should be like you do…
    you can try to give complete pass of xrandr:

    display-setup-script=/usr/bin/xrandr --output DP-3 --primary
    

    And try to run:

    /usr/bin/xrandr --output DP-3 --primary
    

    to see if it gives an error…

    A tip aside: try to use lightdm-gtk-greeter:

    sudo pacman -S lightdm-gtk-greeter lightdm-gtk-greeter-settings
    

    then change /etc/lightdm/lightdm.conf line:

    greeter-session=lightdm-gtk-greeter
    

    run lightdm-gtk-greeter-settings
    and go to "Multimonitor Settings"
    After config reboot system and see how it goes

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • That worked. Now the login followed to whatever screen my mouse was on, and it starts on DP-3. The positioning of the monitors doesn’t seem to be followed, as It still treats them as if they were all in a line, but it’s not a huge deal. Thanks for the help.

  • @joekamprad said in Login screen on wrong monitor:

    should be like you do…
    you can try to give complete pass of xrandr:

    display-setup-script=/usr/bin/xrandr --output DP-3 --primary
    

    And try to run:

    /usr/bin/xrandr --output DP-3 --primary
    

    to see if it gives an error…

    A tip aside: try to use lightdm-gtk-greeter:

    sudo pacman -S lightdm-gtk-greeter lightdm-gtk-greeter-settings
    

    then change /etc/lightdm/lightdm.conf line:

    greeter-session=lightdm-gtk-greeter
    

    run lightdm-gtk-greeter-settings
    and go to "Multimonitor Settings"
    After config reboot system and see how it goes

    Hello…

    I tried to follow your instructions to solve this issue, but I can’t find “Multimonitor Settings”…
    I see four tabs when running “lightdm-gtk-greeter-settings” (Appearance - Panel - Window Position - Misc.) and none of them contains aything about Multimonitor Settings…
    Can you please guide me?
    I have installed latest Antergos iso (antergos-17.5-x86_64.iso) and system is fully updated as of today…
    Thank you in advance…

    Theodore

  • alt text
    alt text

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Of course, you were right… I’m ashamed I didn’t see this, although it was in front of my eyes…
    Clicking on this option I had the next picture
    0_1496325445285_Screenshot-20170601164915-520x469.png
    I added the screen But in order to save the correctly the option, I had to click on something (thus the tick on overwrite default “user-background” option)…
    If nothing is ticked, next run shows this screen empty…
    I rebooted with this option and nothing happened… Login screen is still on laptop’s screen… I then added both screens… Reboot and same result…
    Can any one tell me how to proceed to solve this?
    Thank you

    Theodore

    P.S

    1. I tried to attach my lightdm* conf files, but I may not have enough privileges for this.
    2. I noticed that there is a another file called lightdm-webkit2-greeter.conf which I saw has some settings for antergos login screen… Does it have something to do with login this problem?
    3. In file lightdm.conf I have enabled display-setup-script=/usr/bin/xrandr --output DP-3 --primary
  • Do you install and enable lightdm-gtk-greeter?
    Need to change session greeter option inside lightdm.conf

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Hello @joekamprad

    I just checked

    • lightdm-gtk-greeter and lightdm-gtk-greeter-settings are installed
    • lightdm-webkit2-greeter is also installed
    • file /etc/lightdm/lightdm.conf has uncommented the line greeter-session=lightdm-gtk-greeter

    Theodore

  • @joekamprad

    It seems I was pretty lazy to search all /etc/lightdm/lighdm.conf file…
    A few lines after greeter-session I wrote about, there was another one saying that session-greeter was lightdm-webkit2-greeter…
    I commented and everything is working as you said…
    Thank you very much for your patience…

    Theodore

monitor22 login72 Posts 11Views 1143
Log in to reply