The problem:
My laptop will not boot into the desktop using the Intel HD Graphics 630. The screen is completely black.
However, I can boot into the desktop using the dedicated Nvidia card. But Intel iGPU must be turned off in the BIOS.


  • Clevo P650HS-G Laptop
  • i7-7700HQ (Kaby Lake); Intel HD Graphics 630
  • NVIDIA® GeForce® GTX 1070 with Gsync
  • Antergos 17.3; Gnome: 3.22.2; Linux Kernel: 4.10.3-1
    BIOS Screenshot:

Main Display Drivers Installed:

  • Mesa
  • xf86-video-intel
  • nvidia

I have been reviewing the information below as they both similar components:

What have I done:

  1. Installed Nvidia drivers
  2. Uninstalled Nouveau and blacklisted /etc/modprobe.d/nouveau.conf
options nouveau modeset=0

I can now boot into the desktop using the dedicated Nvidia GPU

  1. Added "MODULES=“intel_agp i915” to /etc/mkinitcpio.conf - Source:
MODULES="intel_agp i915"
  1. Rebuild your initial ramdisk image # mkinitcpio -p linux - Source:
  2. Added /etc/X11/xorg.conf.d/20-nvidia.conf
Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        BusID      "PCI:01:00:00"
        #Option "NoLogo" "true"
        #Option "UseEDID" "false"
        #Option "ConnectedMonitor" "DFP"
  1. Added /etc/X11/xorg.conf.d/30-intel.conf
Section "Device"
        Identifier "Intel Graphics"
        Driver     "intel"
        BusID      "PCI:00:02:0" #Found by turning on Hybrid and booting into terminal with Ubuntu live usb
  1. Installed driver xf86-video-intel

At this point, I restarted the laptop and changed the BIOS setting to “Hybrid graphics”.
Afer GRUB, the screen is completely black.

I intend on setting up Bumblebee later. But I want to ensure the Intel GPU is working first.
I have spent a long time trying various things but at this point, I am stuck.

– Update: Added more system logs in zip file.
Extracted with Really helpful for narrowing by time.