• Like 0

    Gnome doesn't detect ext monitor via HDMI, with VGA works fine


    Hello everyone,
    After banging my head for couple of days making it work with my HP Zbook (dual boot,win 10, Nvidia Prime), I switched to Antergos, and it works and looks great (after blacklisting nouveau).

    My graphics details : (Nvidia recommends 375v for my graphics card)

    Graphics:  Card-1: Intel Skylake Integrated Graphics
               Card-2: NVIDIA GM107GLM [Quadro M2000M]
               Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: nouveau
               Resolution: [email protected]
               GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
               GLX Version: 3.0 Mesa 12.0.6
    

    Now, without installing nvidia and other libs, my connection to external monitor (4K) using VGA works fine but has very low resolution. When I try to connect via HDMI, it doesn’t detect. I am sure it is a nvidia problem, but as soon as I install nvidia drivers on my Antergos, it would not boot up after the boot screen (hangs up at black screen). Even if I then try to uninstall nvidia, it doesn’t works. This is my 4th fresh install of Antergos, please assist me in getting out of this Nvidia nightmare.

    I installed nvidia drivers using

    pacman -S nvidia nvidia-utils 
    pacman -S nvidia-libgl
    

    After launching nvidia-xconfig , computer would stuck at black screen after booting.

    Many thanks for the help.

  • Like 0

    nvidia-xconfig Is no longer recommended, it does not fit with the last changes on Xorg…
    As far as i know it produce a file under /etc/X11/xorg.conf … we have thouse files now under /etc/X11/xorg.conf.d/

    Do you try Antergos tricky package nvidia-installer ?

    sudo pacman -S nvidia-installer
    

    For testing it:

    sudo nvidia-installer -t 
    

    If all looks good run it for real:

    sudo nvidia-installer
    

    if it does not detect your hardware try --force option:
    For testing it:

    sudo nvidia-installer -f  -t 
    

    If all looks good run it for real:

    sudo nvidia-installer -f
    

    About Skylake support:
    https://wiki.archlinux.org/index.php/intel_graphics#Skylake_support

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    Thanks @joekamprad. I did a fresh install now.
    When I try the force option, it says

    Warning:root: Your graphics card is not in our database
    

    Should I run it anyways? or should I install a nvidia driver first?

  • Like 0

    As i say:

    nvidia-installer -f  -t 
    

    With -t Option it will test the installtion, so you can see that it works also if your card is not detectet.
    then install with force option…

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad Alright, I did it now, it just hangs on the black screen, wouldn’t boot up to Gnome.
    I can use TTY though, what do you recommend?

  • Like 0

    you can uninstall nvidia driver with

    sudo nividia-driver -n
    

    this reinstall back to nouveau…

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    but if tyour system is driven by a hybrid card system you may need to install bumblebee?
    nvidia-installer is made for this too…

    sudo nvidia-installer -b
    

    https://antergos.com/wiki/hardware/graphics/bumblebee-for-nvidia-optimus/

    lspci -vnn | grep '\''[030[02]\]' 
    

    If it outputs two lines, then you’re likely having an Optimus laptop.

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    I did it, it still won’t boot up. Here is a picture of the error messages

    alt text

  • Like 0

    you did what? go back to nouveau or install bumblebee option?

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    If you have a otimus hybrid, nouveau will bring also problems.

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad That is right, that is why I am using

    modprobe.blacklist=nouveau
    

    during kernal boot. Otherwise, it wouldn’t boot up as well. Uninstalling nvidia-driver, wouldn’t put the system back in the same state as before. Any further recommendations?

  • Like 0

    wait a second…

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0
    nouveau.blacklist=1
    

    is the command for grub…

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    nvidia-installer do not simple uninstall nvidia it installs nouveau instead of nvidia…
    may you do not boot with nouveau before and now it is inside early startup…
    Can you do :

    cat /etc/X11/xorg.conf
    

    and if it shows you a file remove it

    sudo rm /etc/X11/xorg.conf
    

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad I used this instead of

    modprobe.blacklist=nouveau
    

    and it gets stuck on the black screen.

  • Like 0

    black screen at all or after loginmanager lightdm???

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    i would recomment to go back to you state before try to install nvidia driver…

    sudo nano /etc/mkinitcpio.conf
    

    change the linse

    MODULES="nouveau"
    

    to:

    MODULES=""
    

    then:

    sudo mkinitcpio -p linux
    

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad I add nouveau.blacklist=1 to the kernel and then it gets stuck here (before lightdm I reckon)

    alt text

  • Like 0

    @joekamprad I did this, modules was already empty (MODULES="") and I also deleted xorg.conf file from TTY2, on TTY1, it is still hanged and last error message is

    tpm tpm0: A Tpm error (7) occurred attempting to read a pcr value

    Trying power reboot now, system is hanged.

  • Like 0

    If you can not startup X after what i write before,
    disable Lightdm and use GDM :

    sudo systemctl disable -f lightdm
    
    sudo pacman -S gdm
    
    sudo systemctl enable -f gdm
    

    reboot

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @uksurd Yes, I just see a pointer and black screen, can move pointer after booting. When I try using TTY, it doesn’t respond, stays black with same pointer. Should I use GRUB commandline or try booting in safe mode (CLI)

    This is the log from sudo mkinitcpio -p linux earlier.
    alt text

gnome156 monitor18 ext2 detect3 Posts 36Views 274
Log in to reply